Home Forums Everything about the Tricopter V4 Barometer not working on the v4 F3FC

This topic contains 16 replies, has 9 voices, and was last updated by  norwenkel 2 years, 9 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #31382

    okolloen
    Participant

    In the build video David made a point of adding foam above the barometer. I think I noticed that the barometer was green when I first plugged in the board but not with the new firmware flashed on the board I can not find any way to access the barometer.
    Am I missing something obvious or doesn’t the barometer work with the tricopter firmware?

    #31450

    swissfreek
    Participant

    I haven’t messed with it in the CleanFlight configurator, but it feeds telemetry back to my Taranis, so it’s working for me. Haven’t checked it with today’s 0.5 release, though.

    #31468

    sscott
    Participant

    It works for me on Triflight 0.5 beta 3. As I raise the Tri off the desk, I can see the barometer altitude meter increasing in Triflight (can’t remember exactly which panel it was on).

    I think you may need to upgrade your version of Triflight, as I’m not certain that the F3FC board was fully supported in 0.4.

    #32105

    xtrmtrk
    Participant

    I’m having barometer problems too. On the bench, looking at the Sensors Tab in CleanFlight, I can see the barometer is working correctly. But when I flip on Baro mode, the tricopter throttle goes spastic – totally random and rapid full throttle and then no throttle for random short periods of time. Without intervention, the craft will slam into the ground.

    Looking at the ALT PIDs, I see that the Integral and Derivative factors are 0.0. This doesn’t seem right. I’m using the PIDs from the V4 product page’s “Preconfigured CleanFlight setup” tab. I’m wondering if this is the problem. And if there’s a reasonable solution.

    Edit: Looking at the command line, I see that baro_hardware = 0. This seems bad too!

    It’s looking like David’s setup doesn’t include the barometer.

    Here are all of the barometer and altitude settings:

    baro_tab_size = 21
    baro_noise_lpf = 0.600
    baro_cf_vel = 0.985
    baro_cf_alt = 0.965
    baro_hardware = 0
    alt_hold_deadband = 40
    alt_hold_fast_change = ON
    baro_cf_alt = 0.965
    p_alt = 50
    i_alt = 0
    d_alt = 0

    Edit again – according to the documentation here, “set baro_hardware = 0 (default on), 1 = disabled.” This is opposite of what I’d think, but makes it look like the barometer is at least enabled even if the PIDs might not be reasonable.

    #32135

    okolloen
    Participant

    I will have a look at the baro_hardware related settings, hopefully I can work this out. As it is now cleanflight does not even show that I have a barometer.

    Thanks for the tip xtrmtrk.

    #32257

    wilco1967
    Participant

    Also having issues with the Baro….
    F3FC tricopter frame board. with external compass (5883) and GPS.

    Have mostly been experimenting with iNav firmware (GPS navigation optimised branch of cleanflight).but that works still better as using Tri-flight as far as baro + compass are concerned.
    On tri-flight, The baro simply stops working if I connect the compass… on iNav, at least both sensors can work together.

    There is definitely something not right with the baro.

    With the iNav code, I get proper baro values and mag values (at the same time).
    However, no matter how I try, I can’t get the alt hold tuned…. even if I take out all the I and D of both the alt and vel controllers, it is still very jump…. sometimes it seems to hold just fine, but than suddenly, it rockets up in a series of fast throttle burst,
    Even the slighthes amount of I (0.001) and it will start to go up and down….
    The baro is inside this front spacer, and I even put some cotton over the baro, to stop even the slightest of light getting in through a gap (I can’t see any, but just to be sure). doesn’t make a difference.

    Alt hold wasn’t perfect on the flip32 I used before, but that worked reasonably well.
    Other than the flight controller, everything else is the same hardware. Even used the same PID settings, and it flies pretty much the same as before, except alt holt…

    So I tried Tri-flight, to see if that worked any better.
    With Tri-flight, when I connect the compass, the baro will not work at all…. it doesn’t even see the sensor. The compass works though.
    When I disconnect the compass, the baro starts to work again (after a reboot)….. Very strange.

    So Tri-flight is even worse…. tried both the version from RCexplorer website (6 june ?) and one I found on githup from 24 july.. Both same behaviour.
    .
    If this had anything to do with pull-up resistors on the I2C bus, I would expect it to affect both iNav and Tri-flight the same, but they definitely behave totally different. On iNav, both work (at least, I get normal sensor values, and no I2C errors.)
    Also tried powering the compass from 5V rather then 3.3 V… no difference.

    I’m at a loss….. Any ideas ?

    UPDATE 17-8
    found the problem…. it was after all the pull-up resistors on the external mag… after removing, both baro and compass work together nicely, on iNav as well as Triflight….

    Haven’t tested if this improves alt hold…. will test tomorrow.

    #32679

    Draclicka
    Participant

    Removed my comment due to no response from the community. Will start a new thread with my question.

    #33685

    norwenkel
    Participant

    @wilco1967 Even if is topic is a bit older, can you tell a bit about experiences about your att hold etc. tests and issues. Eg. What PIDs are you using?
    I still have an ardu mag gps combination on the bench and my plan is to connect it to my Mini Tri equipped with F3FC board. Any recommendations are highly appreciated.

    Thanks

    #33700

    wilco1967
    Participant

    @norwenkel

    Althold works now pretty good. But my experiences have all been with iNav, (not cleanflight, triflight, etc.)

    Although it works good now, getting there wasn’t easy….
    have a look at the ‘F3FC & iNav experiences’ thread here on RCExplorer forum

    F3FC & iNav experiences

    my current alt hold settings are:

    set nav_alt_p = 200
    set nav_alt_i = 0
    set nav_alt_d = 0
    set nav_vel_p = 200
    set nav_vel_i = 10
    set nav_vel_d = 40

    but please note: this is for iNav… probably no good for cleanflight (but I’ve never tested).

    #33701

    norwenkel
    Participant

    @wilco1967 thanks a lot for your response.

    #34265

    villalji
    Participant

    Hi, @okolloen I´m having the same issue, my mini-tri flies fine, all seems to be fine, but I cannot see the barometer in Cleanflight with F3FC and Triflight 0.5 beta3. Did you find a solution to it? I was just trying to set up the Altitude Hold mode, and also show the altitude in my minim OSD, but without recognizing the sensor, no way…

    #34267

    neoxio
    Participant

    Try to power the F3FC first with battery then connect the USB cable to PC and check over cleanflight-configurator if the baro is aviable but not other way around. Are you using mayby any other I2C external sensors?

    #34275

    villalji
    Participant

    Hi, thanks @neoxio, I have tried as you suggest, but I still can’t see the barometer in cleanflight. I am not using I2C sensors. I have UART1 in serial mode connected to the Spektrum Sat receiver, and UART3 used for OSD. Any other suggestions?

    #34277

    norwenkel
    Participant

    @villalji give the latest triflight 0.5 a try. https://github.com/lkaino/Triflight/releases do you see any i2c errors?

    #34280

    neoxio
    Participant

    Yes try to reflash the whole lastest triflight like Norbet suggested but use full chip erase option in clanflight firmware-flashing. Then if u still cannot see the baro try to go to cli and set baro_hardware=3 and save, power off battery and power it again and connect to PC.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.