Home Forums Everything about the Bicopter Betaflight 4.0

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by  Claude 1 month, 3 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #62163

    touchthebitum
    Participant

    Hello
    I just built my Bi copter and it seems that Betaflight 4.0 mapping is different from the 3.5 working version. When I throttle up, servos tilt in opposite direction. I tried to paste PID settings but it doesn’t work.
    Any news on it?
    Thanks

    #62584

    Claude
    Participant

    Hi,

    I will start to build my Bicopter tomorrow. I will flash the KakuteF4V2 with Betaflight 4.0.3, and will post the results.

    #62585

    touchthebitum
    Participant

    Good ( crossed fingers) 😉

    #62588

    Kevin_Erik
    Moderator

    If your servos are moving opposite of the intented direction, you should be able to reverse them in Betaflight. Thats the only thing i liked about Betaflight, being able to swap things around or remap Pads as needed. Other than that, its a complete cluster-(insert your choice of explitive here) for non-quads. So much of what people tune for is based on known good pids for specific hardware.

    Here are some of the last Betaflight PID’s i used before swapping to dRonin.
    https://rcexplorer.se/wp-content/uploads/2018/11/LOG00004LOG004_0_response.jpg

    One change I’d make to this right off, is to Zero out the Yaw’s dTerm. Maybe start off with all values 20% lower and tune up from there. Other then that be careful taking the Yaw PID’s higher as they’re right at the point where you’d start to see oscillation. keep in mind that in all of my dRonin tunes the Yaw terms are signifigantly lower than Roll and Roll lower then Pitch ect. This makes the Pitch dominant over the other Axis, which helps to keep the copter stable. Even in reverse flight.

    #62636

    Claude
    Participant

    I just finished assembling and wiring the bicopter.

    I flashed the KakuteF4V2 with betaflight 4.0.3, choose the bicopter profile, re-maped the 2 servos based on the informations here, and the servos move exactly as they should.

    For the remaping, the KakuteF4 wiring description indicates how to wire for the bicopter: left servo signal from M3 pad and right servo signal from LED pad.

    So you have to CLI type :
    resource M3 none
    resource M4 none
    resource LED_STRIP 1 none
    resource servo 1 A03 (previously used for motor 3 signal)
    resource servo 2 C08 (previously used for LED strip signal)
    save

    Betaflight BICOPTER profile should then manage the servos as they should 🙂

    #62637

    touchthebitum
    Participant

    Great !
    Thanks Claude !
    I’ll try that.

    #62638

    Kevin_Erik
    Moderator

    I used the Matek F405-STD paired with the Matek FCHUB PDB and FPV canopy. (Made wiring very simple) Running the Servo voltage at 7.4, having great Yaw response from this setup

    Fpv canopy: https://www.thingiverse.com/thing:3571841

    #62701

    Claude
    Participant

    Hohoho first flight yesterday evening …

    With default PIDs, unable to take off. Increasing wobbling of each servo …

    I played a little bit with the PIDs, a now it flies !!!

    Now I have to solve 2 issues:

    – motors are a little bit hot

    – It sometimes cuts power in the air and fall back to ground. I have to disarm / arm it to take off again. Any clue ?

    #62707

    Kevin_Erik
    Moderator

    You can look over my old Bicopter / Betaflight thread to see what i did. It should show all of the settings used etc.

    Kevin's Bi-Copter Thread

    Off hand though, if your experiencing over heating, then your I and D values are likely too high. Now as for the shutdown in flight, that could be the ESC’s cutting throttle to keep from exploding. (Keep Yaw D @ ZERO)

    I did however experience the same issue a while back. Ensure that you have he following CLI command set to OFF…

    runaway_takeoff_prevention

    #62708

    Claude
    Participant

    I can say the motors are not overheating, they are just warm … and both ESCs are still cold.
    And both motors stop at the same time … Failsafe issue ??? I have to investigate 🙂

    I will try to lower I and D on the different axis …

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.