Home Forums Everything about the Mini Tricopter Can not get board alignment right

This topic contains 5 replies, has 4 voices, and was last updated by  AgentLAL 2 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #36874

    bhuism
    Participant

    With my brand new F3FC Tricopter Frame (with integrated Power distribution) running fresh flashed+full chip erase cleanflight v1.14.2, I can not get the animation to correlate with the fysical movement of the copter, with board alignment pitch 180 degrees (conform specification), the yaw is inverted (does not correlate). With board alignment pitch 0 degrees, the roll is inverted (does not correlate).
    Here comes the weird part, on another brand new F3FC Tricopter Frame (with integrated Power distribution), when I set pitch board alignment to 180 everything is correct conform specification.

    Any ideas? maybe even a hardware failure?

    #36899

    Did you do a accelerometer calibration after setting the board to 180 (with the correct side up)?

    #36911

    AR
    Participant

    Yes, we did. Bhuism is very experienced with copters and building RCexplorer tricopters since the V1 and helping me with this issue.

    We get the same weird behaviour on this board in Triflight, Betaflight and Cleanflight. And the today received second board is working flawlessly. I can’t think of any other possibility then hardware failure. RMA?

    #36942

    Got your ticket.
    Super weird problem.
    We’ll sort it out

    #37353

    AgentLAL
    Participant

    I am having this exact problem, except with a board that worked flawlessly until now. I recently replaced an arm, so I think it may be a physical problem, like something is fried. The reason I am posting on this forum is because I am getting ready for Flite Fest West, and I know the board won’t arrive in time, I am also wondering if you,(David Windiest√•l, sorry if I didn’t spell the name correctly) are going to have some extra boards, or just selling some, if you are coming to Flite Fest West.

    Thanks, Liam.

    #37378

    AgentLAL
    Participant

    UPDATE-I solved your accelerometer problem. It is a glitch in the accelerometer that causes the yaw to be reversed. I tapped on the accelerometer and it fixed it.

    When you get this problem, just take the tricopter apart and tap on the accelerometer. It works fine afterwards, except for if it is banged too much it gets glitchy again.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.