Home Forums Everything about the Tricopter LR dRonin GPS and VTX setup

This topic contains 11 replies, has 2 voices, and was last updated by  PeterPankras 1 month, 3 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #63424

    PeterPankras
    Participant

    So after my first autotune flight I added the rest of the hardware to the Tricopter LR and it is now time to finish it to get flying.

    I have connected the gps (bn-220) to uart 4, but when I go in the hardware setup in dRonin I cannot set uart 4 to GPS???

    Then the VTX is a Tramp HV, and I got the telemetry (T wire) connected to UART 6, but again I see no option at that uart to set it to some sort of smartaudio option.

    Am I missing anything?

    Can I switch the pin configuration in dRonin like you can in betaflight cli?

    And how do I enable some kind of OSD? my camera is working and I got image, but there is no OSD info on screen anywhere?

    #63425

    jihlein
    Participant

    Looking at the hardware tabs, for Uart4 there’s a GPS option, and for Uart6 there’s a VTX Config for Smart Audio. This is exactly the config I use. But for what it’s worth, I’ve only seen the Smart Audio function work with TBS video transmitters, haven’t been able to figure out why yet.

    While on the hardware tab, enable the OSD.

    There’s no need for BetaFlight like resource management due to the way Uarts and Motor/Servo outputs are setup.

    #63426

    PeterPankras
    Participant

    Then I will have to check again tonight.
    I did not have a GPS option for uart 4. Only nothing and another one (that I cannot remember the name of)

    Sad that the tramp probably does not work, I hate switching channels manually with the buttons.

    • This reply was modified 1 month, 3 weeks ago by  PeterPankras.
    #63428

    PeterPankras
    Participant

    So, home checking settings in dRonin.

    Enabling OSD in the hardware tab worked turning the OSD on 😀 Now I need to see if there is a way to modify it. But that is something for later.

    UART 4 in the hardware tab only had a DISABLED and OPENLOG option.

    UART 5 and 6 do have a GPS option.

    Shame I cannot control the Tramp, but when switching to long range hopefully later I will get a TBS VTX anyway.

    I think the best option now is to desolder the GPS from UART 4 and move it to 6.

    #63429

    jihlein
    Participant

    “I think the best option now is to desolder the GPS from UART 4 and move it to 6.”

    Or download the latest version from the installers thread, you’re running an older version.

    #63430

    PeterPankras
    Participant

    I used the one that comes with the installer here https://rcexplorer.se/forums/topic/dronin-installers/

    Is there a newer version? I thought this was the latest.

    #63431

    jihlein
    Participant

    That is the latest, something else odd is going on as UART4 should have all the options including GPS. Which FC are you using? Also please post a screenshot of the firmware tab contents.

    #63432

    PeterPankras
    Participant

    It’s a Kakute F4 V2, from David

    Attachments:
    #63435

    jihlein
    Participant

    That’s not the firmware you download from here:

    dRonin Installers

    Yours is 20190112, the above is 20190605

    Upgrading to that should solve the missing uart options.

    #63439

    PeterPankras
    Participant

    Thanx, I will upgrade.
    But first I’ll fly it like it is without the working gps 🙂

    If I upgrade do I then have to do the whole setup again? Or can I somehow save all my settings , upgrade and use my previous settings.
    Asking for a friend who does not want to go through the whole setup procedure again 😉

    #63444

    jihlein
    Participant

    There’s an auto update function that “usually” works when you update the firmware via the GCS. It’s self prompting. Be warned though that it’s not always 100% perfect, you need to carefully check everything after the process completes.

    Because of that, I always make a manual backup copy of the settings using the “File->Export UAV Settings” function of the GCS.

    #63455

    PeterPankras
    Participant

    Updated dRonin and the firmware tonight, worked like a Charm!

    I was able to select GPS for UART4 now, and it is activated now.
    Will have to test tommorow outside as I cannot get a position fix inside.

    I like to test with the GPS, I know return to home does not work.
    Do you think you can fly the tri in waypoint mode with the gps?

    Anyway, I now have to start tuning.
    Did a testflight this afternoon, and a first fpv flight with the tri to see how it behaved.

    The tail needs tuning as it seems to wobble/oscillate.

    Thanx again for the help!

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.