Home Forums Everything about the Tricopter V4 F3FC reports extreme current draw

This topic contains 60 replies, has 18 voices, and was last updated by  Wiytboi 1 year, 2 months ago.

Viewing 15 posts - 16 through 30 (of 61 total)
  • Author
    Posts
  • #31826

    drame
    Participant

    I’m using the exact same OSD and also UART2.

    #31830

    sscott
    Participant

    Perhaps the UART2 pins are being used as a voltage reference for the ADC? Therefore, when you connect the minimOSD to UART2, it messes with the voltage reference, causing the ADC to read the incorrect current value. I don’t know, just thinking out aloud here…

    Since David hasn’t published the schematics, this might be an issue that only him and Lauka can fix.

    #31834

    drame
    Participant

    Interesting theory but at least from a code standpoint that is not the case.
    And David already said that the current sensor is not even remotely connected to the UART2 pins.

    I have to do more testing if the OSD still causes the Amp reading to freak out but at the moment even on UART2 this seems to not be the case anymore for me.

    In the meantime I updated the FC to Triflight 0.5 release.

    I just did another test – OSD connected to seperate BEC, FC connected via USB and Battery plugged in.
    When I plugged in the RXTX + GND of UART2 to the OSD there was no change in the reported Battery current.
    So this problems seems to have resolved itself. I will test again in the evening with video to confirm that the UART2 is still working ^^

    For me the only problem that seems to be left is the overall incorrect readings of the current sensor.

    #31835

    Daniel_Karlsson
    Participant

    I also tried to connect the minimosd to UART2 and the minimosd-2nd stage to the TX BEC and failed + got the wierd beeping when connected via USB. It works ok on UART1. Had even more problems trying to power LEDs via UART at the same time as powering minimosd…

    Could the two-stage approach used by minimosd be the cause? Have anyone tried to solder the bridges to remove the need for the 2nd stage?

    See wiring examples here
    http://ardupilot.org/copter/docs/common-minim-osd-quick-installation-guide.html

    #31871

    mioh
    Participant

    Thank you Mikael for show me this thread.

    5V and ground to my Minim Micro OSD comes from UART2 or UART3, just like RX and TX.

    Using F3FC and OSD connected to UART 2 voltage, altitude, horizon bar and timer readings are showing correctly. Only the ampere readings showing wrong values. On UART1 I got an OrangeRX.

    This is my values on UART2

    This is what Cleanflight showing:
    1a.) Disarmed (no VTX, no OSD) = 0.13 A
    1b.) Disarmed (VTX, no OSD) = 0.33 – 0.44 A
    1c.) Disarmed (VTX, OSD) = 8.5 A

    2a.) Armed (motors spins slowly, no VTX, no OSD) = 0.50 – 0.91 A
    2b.) Armed (motors spins slowly, VTX, no OSD) = 0.52 – 0.80 A
    2c.) Armed (motors spins slowly, VTX, OSD) = 8.50 – 8.92 A

    And regardless USB connected or not, with all connected MWOsd show this shows in my googles :
    3a. ) Armed = 8.6 A
    3b. ) Disarmed = 8.5 A

    And today I tested OSD on UART3. This is the result with the MWOsd on UART3.

    This is what Cleanflight showing:
    1a.) Disarmed (no VTX, no OSD) = 0.16 A
    1b.) Disarmed (VTX, no OSD) = 0.16 A
    1c.) Disarmed (VTX, OSD) = 0.47 – 0.83 A

    2a.) Armed (motors spins slowly, no VTX, no OSD) = 0.55 – 0.86 A
    2b.) Armed (motors spins slowly, VTX, no OSD) = 0.53 – 0.91 A
    2c.) Armed (motors spins slowly, VTX, OSD) = 0.66 – 0.80 A

    And regardless USB connected or not, with all connected MWOsd show this shows in my googles :
    3a. ) Armed = NO DATA
    3b. ) Disarmed = NO DATA

    So then I’m using UART3 my micro minim MWOsd, cleanflight reports good values but the MWOsd got no data at all. No volt, no ampere, no height, no horizon bar, no nothing. 🙁

    UART2 and UART3 got the same ports settings in Cleanflight. MPS on with 115200, Blackbox off, Telemetry disabled AUTO, RX and GPS off.

    Have this Micro Minim OSD. http://www.rctech.se/index.php?route=product/product&product_id=316& with MWOsd R1.6 on it.

    #31883

    bassmaniac
    Participant

    Interesting reading this thread, as I am contemplating a microminimOSD. doing some reading, this OSD has a current draw of 0.5A at 5V, so quite hungry for such a small device.

    #32098

    Carl
    Participant

    I had the same problem using UART2 for OSD. Moving to UART1 seems to chow correct values.

    /Carl

    #32100

    Carl
    Participant

    OK, so in cleanflight I get correct values for current draw when connected to UART1 or 3 and wrong (around 10A) when connected to UART2. Problem I have with connecting to 1 or 3 is that I can not turn on MSP on UART1 and I am not getting any data on UART3. So the only port I get data to my OSD is on port 2 which in turn makes the current draw values completely wrong 🙁

    Also using minimOSD micro.

    EDIT: SOLVED! I turned MSP off on both UART2 and 3, saved/rebooted, then turned it back on for UART3. Now I get data on UART3 and my current sensor values seem correct.

    /Carl

    #32112

    mcstan
    Participant

    I have the same issue..

    does not matter which port I use but if cleanflight has the msp is switch on for the osd it reads 14 amps but if you switch it off it reads right inside cleanflight…

    really don’t get it at all… all the osd and cam and VTX are powered from there own bec.. because i run my fcf3 board at v6 for the servo.. + i read too many scary story’s people killing it the internal.

    #32114

    Carl
    Participant

    I don’t think the problem is with the power to the osd. Atleast it makes no difference for me. Seems to have to do with which port tx/rx is plugged into. So a stand alone bec will not solve the problem.

    /Carl

    #32138

    Can you guys try the latest 0.5 firmware to see if that does any difference? https://github.com/lkaino/Triflight/releases/download/0.5/triflight_0_5_F3FC.hex

    #32142

    mcstan
    Participant

    I had the issue on the other versions and I have flashed to 0.5 triflight and i still get it… its so weird… I don’t get why soon as you switch the MSP on the UART where i have the OSD plugged in to.. cleanflight start reading 14a and i only have it plugged in to the USB port on my computer and no battery.

    #32146

    Mikael
    Participant

    My experience is exactly like @mcstan‘s. I’ve tested Beta 3 (which come with the boards), Alpha 2 and finally the 0.5 release. I’m not entirely sure all releases behaved the same way as I wasn’t aware that the problem was related to UART2 until august 1 (http://rcexplorer.se/forums/topic/f3fc-reports-extreme-current-draw/#post-31824), at which point I was using the final 0.5 release.

    @david, if it’s of any help I can send you the micro minimOSD I’m using. It seems as many people experiencing this type of problems are using that model.
    Since I’m in Sweden you could have it by tomorrow or at latest by Thursday. Let me know!

    #32190

    That would be awesome Mikael!
    Would love to troubleshoot this

    #32325

    mcstan
    Participant

    Hi guys

    Did Mikael send you the osd to work this crazy thing out?

Viewing 15 posts - 16 through 30 (of 61 total)

You must be logged in to reply to this topic.