Home Forums Everything about the Mini Tricopter Interested in Father / Son project

Viewing 15 posts - 16 through 30 (of 60 total)
  • Author
    Posts
  • #38903
    Kevin_Erik
    Moderator

    Returning the “FrSky Taranis X9D” as i found the same transmitter elsewhere for 50% less.

    #38911
    Kevin_Erik
    Moderator

    Received the mini-tri build kit today!

    ***First impressions***
    -Packing was well planned and organized. Box was much smaller than I had imagined and I expect this helps reduce both shipping costs and time to destination. Gotta love that new drone smell!

    -Carbon fiber parts are extremely well made. Was shocked to see them so precisely cut and well finished. My son (Erik) was blown away by how light they were.

    ***Left / Right arm builds***
    -The “270mm-power-and-signal-wires-for-escs” is pretty much required and should be added to the overall electronics kit. Either that or make a note on the Mini Tricopter page that these should be purchased as well.

    -All three ESC’s need the “short” power and signal wires removed as well as any remaining excess solder cleaned off from the pads. I recommend that this be performed with a medium soldering flat-tip @ 400C. Luckily I have a soldering station so this wasn’t too big of a deal. However, for those not experienced with soldering, it’s possible to overheat to ESC’s components due to the amount of heat-soak required to loosen the old solder. (A heat sink can help here) Furthermore, it’s possible to accidentally create a bridge between one or more pads or components if care is not taken.

    Note: Having solder-wick helps a ton when removing old solder from pads.

    -The prop adaptor(s) shown in the video were not part of the kit. I’m guessing that these are no longer required as I can see that the motor hub lack screw holes for such an attachment. Can you please confirm this?

    -The attachment of the motor wires to the ESC’s pads (A thru C) is pretty hard to see in the video. Would be helpful if the wires were labeled indicating the proper sequence.

    #38939
    Kevin_Erik
    Moderator

    *** F3FC Wiring and Build up ***
    -From what I could tell from watching the older video’s of the mini-tricopter, what came before the F3FC was pretty clunky. Dam glad the F3FC was avalible for our build. However I would suggest that the mini-copter build video be updated to reflect the accumulated updates.

    #38947
    Kevin_Erik
    Moderator

    Unable to access the min-copter via clean flight.

    Cleanflight shows the following “Failed to open serial port”…

    Steps taken
    -Zadig started in “Admin” mode.
    -Connecting the drone via the USB (button held while inserting), connect tone present.
    -All devices listed (Zadig) and STM32 Virtual Com port selected.
    -Driver WinUSB V6.1.7600.16385 installed (Zadig)
    -Cleanflight app loaded up.
    -Firmware successfully flashed with local file “triflight_0_5_ALPHA2_servo_release_RCE.hex”
    -When attempting to connect, log shows failed to connect.

    Note: Attached device (STM32) is correctly shown under Windows device manager. Tried two seperate USB cables but drone unpowered except for USB 5VDC.

    Cleanflight Log
    2017-08-04 @ 13:09:50 — Running – OS: Windows, Chrome: 59.0.3071.115, Configurator: 2.1.0
    2017-08-04 @ 13:09:54 — Using cached release information.
    2017-08-04 @ 13:09:57 — USB device successfully opened with ID: 3
    2017-08-04 @ 13:09:57 — Detected device with total flash size 256 kiB
    2017-08-04 @ 13:09:57 — Read protection not active
    2017-08-04 @ 13:10:00 — Erased 118 kB of flash successfully
    2017-08-04 @ 13:10:05 — USB device successfully closed
    2017-08-04 @ 13:10:12 — Failed to open serial port

    Anyone know whats going on with this ?

    #38948
    LitterBug
    Participant

    The current CleanFlight configurator is not compatible with the older firmware. You should use the latest TriFlight 0.7 Beta2 and the BetaFlight Configurator. If you want to use the older TriFlight 0.5 release, you will have to install the old CleanFlight configurator.

    Cheers!
    LitterBug

    #38949
    Kevin_Erik
    Moderator

    Thanks Litterbug!

    OK now, I’ve the BetaFlight Configurator downloaded…

    Looking for the TriFlight 0.7 Beta2 on https://github.com/lkaino/Triflight/releases/0.7-beta2
    Just a guess but its the file named “triflight_0.7_Beta2_RCEXPLORERF3.hex” right ?

    #38950
    Kevin_Erik
    Moderator

    Betaflight log from 1st attempt, flashed and programed F3FC, then fails to connect…

    2017-08-04 @ 16:52:30 — USB device successfully opened with ID: 2
    2017-08-04 @ 16:52:30 — Detected device with total flash size 256 kiB
    2017-08-04 @ 16:52:30 — Read protection not active
    2017-08-04 @ 16:52:42 — USB device successfully closed
    2017-08-04 @ 16:52:45 — Failed to open serial port

    #38957
    Kevin_Erik
    Moderator

    So far I’ve tried Cleanflight and Betaflight without luck.

    I’m thinking this is a comms / driver issue of some form. Even attempted doing a safeboot with driver signature enforcement disabled without any noticeable change.

    Will try the sequence via my wife’s laptop but I’m not overly optimistic as it too is a Windows machine.

    #38958
    Kevin_Erik
    Moderator

    Woot!

    Got in via a combination of my wife’s old laptop & Betaflight!!!

    #38959
    Kevin_Erik
    Moderator

    Accelerometer calibration successful.

    #39033
    Kevin_Erik
    Moderator

    Progress
    1) Frsky Taranis Transmitter and Frsky XM+ receiver both updated with the latest firmware. (EU)
    2) Frsky XM+ Receiver board bound to Taranis Transmitter. (Fail safe too)
    3) All batteries charged except the battery for FPV goggles. Awaiting parts to build 5.5mm Adapter to xt60. Using xt60 (female) and 5.5mm barrel (male). Sucks that this isn’t available online nor with the charger.
    4) Video camera and vtx installed and verified working via external monitor. However the video looks as if it’s shot from a fisheye lense. Either this needs corrected or replaced. May opt to replace as the camera doesn’t fit the camera mount properly. Unfortunately finding a board based camera remains an issue.

    Note: Rigging up the cabling for the video and vtx has been by far the biggest headache of the build. None of the connectors are standardized and often one or more connectors needs to be rewired or replaced outright.

    Major issue (Need Help)
    -Connecting to the tricopter via Betaflight is a constant issue. Zadig loaded and still after the F3FC firmware update, I’m unable to load into the configuration screen. Be aware that I was able to get it to work once on my wife’s laptop. However recently even this is failing to connect. Not sure what i can do as this issue persists on both my PC and now my wife’s Laptop.

    Current build…

    Just under 600 grams with props and battery.

    #39038
    Kevin_Erik
    Moderator

    Odds are the STM32 virtual com port driver is causing issues and I dont see why.

    Tried reinstalling all drivers but yet same issue… Can load firmware but not load into Betaflight’s configuration for the F3FC flight controller.

    Example:
    -Insert the USB cable to the F3FC board (boot button held) and the “STM32 Bootloader” shows in the device manager. Lights are shown on F3FC board and PC recognizes the new device.
    -Load-in and install the firmware to the F3FC from Betaflight(v3.2.1) “triflight_0.7_Beta2_RCEXPLORERF3.hex” after which the Bootloader kicks off and becomes the “STM32 Virtual Com Port”.
    -Past this point Betaflight will not allow me to connect to the virtual device and says “Failed to open serial port”

    Attempts to reinstall en.stsw-stm32102.zip / CP210x_Windows_Drivers.zip and use Zadig have no effect.

    Anyone know whats going on here?

    Kevin

    #39079
    Kevin_Erik
    Moderator

    Was Finally able to get the Betaflight working after downloading “ImpulseRC_Driver_Fixer.exe” from: http://www.dronetrest.com/t/fix-any-stm32-dfu-drivers-issues-when-flashing-betaflight-cleanflight-firmware/3603

    With this I was able to access the flight configuration and verify that the tri-copters receiver is paired with its RC transmitter correctly. During further examination, Motor #1 (tail) is pulsing, which makes me think that there’s a cold solder joint somewhere or a damaged ESC. Motor #2 (right front) works great! Motor #3 (front left) is spinning the wrong way and needs a few wires swapped.

    I’ve yet setup flight controls and special switches and as such not tested the tail servo. Will have a go at this once the motors are all spinning the right way and not pulsing.

    Note: If all goes well the parts for the battery adapter will come in tomorrow so i can finally charge of the FPV goggles battery.

    Kevin

    #39083
    biggestRCEfan
    Participant

    Kevin, the fish-eye look is normal for FPV cameras as you need a wide field of view to allow situational awareness while flying. But you have a choice on the fov by selecting the appropriate lense.

    #39084
    Kevin_Erik
    Moderator

    Thanks BigRC,

    Will give different lens a look… However It does strike me as odd that this is possible with a cell phone camera but not for RC applications.

    As for the motors.

    Motor #3 (front left) wires swapped and works perfectly!

    Motor #1 (tail) reflowed all connections and replaces control wires (white / black 20 gage) but yet the motor still pulses rather than spins. It’s possible I guess that one of the power wires from the board to the esc could have a break mid line but that is extremely rare. I’ll give the esc an alcohol cleaning while rubbing it with a cosmetic brush. This should remove any solder-balls (if any as I did look before) while drying quickly, without leaving a residue.

Viewing 15 posts - 16 through 30 (of 60 total)
  • The forum ‘Everything about the Mini Tricopter’ is closed to new topics and replies.