Home Forums Everything about everything else Multiwii experts?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #12081

    I have a Flip EZ Multiwii flight board that I recently picked up and am having an issue connecting to Baseflight. It will connect with MultiWii Config, but not Baseflight or Cleanflight.

    It says “serial port successfully opened”, then “no configuration received, serial port closed” 10 seconds later.

    When I try to flash Baseflight fw, it says “no response from the bootloader, programming failed”.

    This is on a Mac, Baseflight and SiLabs USB driver all up to date, and is supposed to be as plug and play on Baseflight as a Naze32, etc.


    You need to flash it with Baseflight firmware prior to connecting to it. I know it sounds backwards. Use the firmware flasher tab to do so.


    That had me stuck with my first similar board, a Naze32, before I came across some info specifying the FW flash to start. But that is what I tried here and it is still seeming to have a problem with being able to connect and do that.


    Funny now that you mention it, when using my Mac I had the same response:

    “no response from the bootloader, programming failed”

    From my Cleanflight the other day. Ended up using my Ubuntu box instead. Afterwards I tried again from the Mac and now it does connect. Somehow the Mac did not connect on dev/tty.SLAB_USBtoUART. Are you connecting on dev/tty.SLAB_USBtoUART or dev/cu.SLAB_USBtoUART ?

    – And the really silly question: Is your USB cable connected for sure? Are there lights lid on the board?


    I have used both /tty and /cu port each time. I also have more than one micro usb and all seem to work. I think this board only has two lights that are not next to each other, one showing power and the other showing armed or blinking status, but I do not know the specs. The board will arm and spin up, but has issues that the MWC GUI does not seem to access.

    I’m not sure the Arduino IDE is connecting either or what Board to choose from the Tools menu and always says Error compiling when I try to verify or upload with the correct port selected.

    The description of the board says Atmega328 MultiWii. And I found a post of someone saying they were able to connect a Flip EZ board directly up to Baseflight like any other similar board, but not having a lot of luck finding how to do that right now. The vendor is not known for being especially responsive, but I sent inquiry anyway and have had nothing there either.


    This page will help you out. If you are using windows 7 you may have to install other drivers for the uart usb adapter that’s built in to the board. Not 100% sure but the board to choose from is the pro mini 15mhz. If windows 7 is having problems with connecting to the board you may have to pull the drivers from arduino. I’ve had to do that. Win7 will warn that the drivers are not signed. If the multiwii gui don’t show a tri or quad on it the board is not programmed. Hope that don’t sound crazy



    Ooops! I forgot to put the link in. Hehehe


    This thread was mostly sorted here, @ #3986.

Viewing 8 posts - 1 through 8 (of 8 total)
  • The forum ‘Everything about everything else’ is closed to new topics and replies.