Home Forums Everything about the Baby Tricopter New Build: Baby Tricopter #2

This topic contains 50 replies, has 7 voices, and was last updated by  jihlein 1 year, 1 month ago.

Viewing 15 posts - 1 through 15 (of 51 total)
  • Author
    Posts
  • #37010

    LitterBug
    Participant

    Looking forward to the next chapter of TriFlight. Started building a second Baby with some beefier motors this go round. Baby#1 only has 2100kv motors and can feel a bit laggy at times. Stepping it up to 2207 2450kv this go round. Just need another DMS210 to finish it up. Thought I had put it in my basket, but only had the replacement gears. Should be finished in the next week or two.

    Cheers!
    LitterBug

    Attachments:
    #37187

    LitterBug
    Participant

    Servo arrived yesterday so I’ll have this puppy up and running on TriFlight 0.7 B1 soon!

    Cheers!
    LitterBug

    #37202

    LitterBug
    Participant

    Working on initial bench configuration and testing of Baby Tri #2. Flashed with TriFlight 0.7 Beta1 and have done all the initial configuration for ESCs, RX, Flight modes, and enabled MSP for the OSD. Majority of the config was already defined for the standard RCExplorer F3FC tricopter layout. Most of the work was configuring RX and flight modes.
    Pad 1 = Tail motor (CCW)
    Pad 2 = Servo
    Pad 3 = Right Front motor (CW)
    Pad 4 = Left Front motor (CCW)

    Performed ground Tailtune which defines Left, center, and right servo values and automatic servo speed calculation. My parameters so far:

    CLI
    
    # diff
    # Triflight 0.7 Beta 1 / RCEXPLORERF3 3.1.6 Apr  9 2017 / 13:08:24 (bf500bf)
    servo 5 1096 1930 1487 40 40 100 -1
    
    feature CURRENT_METER
    map TAER1234
    serial 0 1 115200 57600 0 115200
    serial 1 64 115200 57600 0 115200
    aux 0 0 1 1450 2050
    aux 1 27 1 1950 2050
    aux 2 1 0 1450 1550
    aux 3 2 0 1950 2050
    aux 4 12 2 1450 1550
    aux 5 30 2 1950 2050
    set min_throttle = 1035
    set serialrx_provider = SPEK2048
    set deadband = 5
    set yaw_deadband = 5
    set tri_tail_servo_speed = 294
    profile 0
    
    rateprofile 0
    rateprofile 0

    Just need to finish wiring up the OSD/VTX and will be ready to hit the air.

    Build Specs:
    Frame: RC Explorer Baby Tricopter
    FC: RC Explorer F3FC Racing running Triflight 0.7 Beta 1
    RX: LemonRX LM0037 dsmx diversity satellite
    PDB: RC Explorer Baby PDB
    Servo: RC Explorer 210DMH Feedback
    ESCs: Spedix ES30 HV
    Motors: Cobra 2207 2450kv
    VTX/OSD: Diatone SP3
    Camera: Runcam swift
    Props: DALPROP 5045 tri

    Based on previous success, MWOSD connected on UART1, RX on UART2, Logging on UART3.

    Cheers!
    LitterBug

    #37325

    fpvlog
    Participant

    So do you prefer Triflight 0.7 or Dronin so far?

    Cheers 😉

    #37333

    LitterBug
    Participant

    @fpvlog I’ll have to get back to you. I have not flown 0.7 yet but weather permitting, should be maidening this build this week. The dRonin build I’m using is a development fork. So far it has been better than TriFlight 0.5. That may all be due to how well the dRonin autotune works. I never really had my baby tri dialed in PID wise on TF 0.5. I’ll be posting up comparison FPV video soon.

    Cheers!
    LitterBug

    #37917

    LitterBug
    Participant

    This puppy has been in limbo far too long. This WILL be completed and flown this week. Just need to work out the OSD issues I was having. Micro Minim OSDs and cameras can be finicky buggers to get matched up some times… Flashing TriFlight0.7Beta2 today and should have tail tunes and LOS tests done today between showers.

    Cheers!
    LitterBug

    #37933

    phasor
    Participant

    Please post again after using the beta2 as I should be receiving my baby tricopter kit this week.

    Anxiously following this thread, Jerry

    #37939

    LitterBug
    Participant

    I have Beta2 flashed and have done a few LOS flights with no issue. Still trying to get a good in-flight tail tune. May need to reduce Yaw PId or do some adjustments to filtering. MinimOSD on UART1, RX on UART2, so UART3 is free for serial devices. Going to add a serial openlog on UART3 so I can get blackbox logs and figure out what is going on.

    Cheers!
    LitterBug

    #37940

    phasor
    Participant

    Good news…I look forward to my build so may have some questions. This is a great resource.

    Jerry

    #37942

    LitterBug
    Participant

    Baby Tri #2 complete! YAY! Did some disassembly to add FC soft mounts and found a few screws loose on the FC stack. DOH! Threw a set of 8mm Rubber bobbins on between the PDB and FC and double checked everything was tight on the whole build. Finally figured out the FPV problem too. Camera connector had a bad crimp on the signal wire from the factory. DOH!… Replaced that and screwed it all together. Added a connector for an OpenLager for blackbox, etc… So if the softmounting and loose screw fixing doesn’t fix the Tailtune, I’ll be able to look at the blackbox logs to see what’s going on.

    Got the Darth Vader look going on instead of the bumble bee this go round:

    #38623

    LitterBug
    Participant

    After a flyaway on Baby Tri #1 which exploded the tail, bent the Servo output shaft, and broke the servo case, I did a complete rebuild with all new electronics, motors, and servo. Currently using a Turnigy TGY-211DMH servo which has a bit less torque but higher speed. Ground calibration has servo speed at 384 on 6V. Haven’t decided if I’ll switch to the RCE BlueBird Servo when it arrives. May use it on a RCExplorer Mini Tri that should be on it’s way soon.

    Baby Tri #1 COMPLETE REBUILD specs….
    Frame: RCExplorer Baby Tricopter
    FC/PDB: RCExplorer F3FC Racing and Baby PDB
    RX: LemonRX LM0037 diversity
    OSD/VTX: Diatone SP3. MinimOSD/VTX MWOSD 1.7
    Camera: Runcam Swift with GoPro style lens
    V/antenna: TBS triumph
    ESCs: Spedix IS 30A
    Motors: Edge Racing Light 2205 2480kv
    Props: Strix 5×4.5×3
    Servo: Turnigy TGY-211DMH
    Serial Data logger: OpenLager

    Attached pics of the dead servo, and The almost complete rebuild

    Cheers!
    LitterBug

    EDIT: Will be actively testing both TriFlight0.7 Beta2 V6 and dRonin with the TriFlight0.7 routines added in on both frames.

    #38627

    LitterBug
    Participant

    Got Baby #1 all buttoned up and managed to squeak some LOS and an in-air tail-tune in between storms. ROCK SOLID. No waggle on arm. Really looking forward to maiden FPV with all the new gear!

    Cheers!
    LitterBug

    #38647

    LitterBug
    Participant

    Been working with the folks that develop dRonin some more lately and they have been working on integrating the TriFlight 0.7 routines into dRonin. This is the results of the latest build and I think this is the best my tris have ever flown. From Baby Tri #2:

    The dRonin autotune has the roll and pitch axis locked solid. Still need to work on the yaw. Had to tell it to leave yaw on defaults.

    Tried to get my rebuild of baby tri #1 to fly it, but had some heavy tail oscillations and couldn’t get an autotune to run will work on that build later this week. Did get a maiden in running the TriFlight Beta2 V6 firmware. It behaved fairly well but had the same low speed yaw oscillations that I’ve had in the past.

    Cheers!
    LitterBug

    #38692

    LitterBug
    Participant

    Made it to Flite Fest East ’17 with both Baby Tricopters. Spent most of my time volunteering and helping people out in the build tent. What a blast!!! Managed to get a handful of LOS flights in with the Baby Tricopters, and gave a handful of demo flights for people, but didn’t want to risk somebody plugging in a whoop on top of me while flying FPV with them. I left that for some of my beater quads.

    Cheers!
    LitterBug

    #40707

    LitterBug
    Participant

    Weather here is not conducive to outdoor flying, so I’ve been reviewing footage from all my warm weather flying last year. Having been away from the tris for a while, I Gotta say, the dRonin firmware flights look much better even without any yaw tuning. Roll/pitch locked in tight after autotune. See above for an example….

    Cheers!
    LitterBug

Viewing 15 posts - 1 through 15 (of 51 total)

You must be logged in to reply to this topic.