Home Forums Everything about the Tricopter V4 Receiver is suddenly freaking out

This topic contains 2 replies, has 2 voices, and was last updated by  acdi01 2 years, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #33904

    drame
    Participant

    Hello Guys,

    I had my first 2 or 3 flights with the tri and everything went great with no crashes.
    Since then my tri was sitting indoors waiting for the next flight.
    In the meantime I created a new model on my Spektrum DX6 and started a new Configuration in Cleanflight. I setup everything but when it came to adjusting the subtrims and travel endpoints my receiver started acting weirdly with values jumping around all over the range.

    I took my tri apart, thinking that maybe a piece of gras is causing the issue. After taking everything apart and putting it back together again, the problem seemed to be gone.
    When I tried to takeoff today, the tri would always do a roll to the left or try to do a backflip when applying throttle.

    I packed everything up and when I got home I restored the old configuration and model. I managed to hover it for 10 Seconds, landed and then suddenly my motors went crazy and i couldnt disarm. No Inputs made it to the tri.
    Fortunately it didn’t take off and I managed to unplug the battery without getting into the spinning propellers.

    I removed the props and plugged in in to the pc and made a video of the receiver freaking out:
    https://goo.gl/photos/wD1uqpzmB5mx3Tmy8
    I don’t know if this is an issue of the FC or the receiver is broken.
    The LED on the receiver goes off randomly when the weirdness starts. Sadly it is hard for me to measure the voltage from the FC to the receiver to eliminate the BEC as the cause of the problem.

    I was tinkering around with the micro minim OSD a while ago before I gave up and started learning to fly before wiring everything up. David noticed in this post http://rcexplorer.se/forums/topic/f3fc-reports-extreme-current-draw/page/3/#post-32879
    that unplugging the osd while the board is powered could fry the processor. Maybe this happened and it took some time to become noticible? I had my successfull flights after I tried connecting the OSD though and everything was fine then.

    Sadly I don’t have another PPM or Sbus receiver lying around to eliminate the reveicer as possible cause of the problem.

    Has anyone experienced something like this before or has any ideas what I could try?

    #33918

    drame
    Participant

    I’m pretty sure it is the receiver. When connecting servos and an ESC to the PWM channels only the throttle, gear and aux channel output signals. Aileron, Elevator and Rudder seem to be dead.

    Can anyone suggest a good F3FC compatible Spektrum Receiver (PPM or sBUS)?

    The one I currently have is this href=”http://www.banggood.com/2_4G-6CH-S603-Receiver-Supported-JR-Spektrun-DSM-X-DSM2-Transmitter-p-961733.html” target=”_blank”>Receiver.

    Thanks in advance

    #33919

    acdi01
    Participant

    I use the orange rx v2 sbus version. It seems to be working well. I think you can only get it on hobbyking though.
    -Alex

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.