Home Forums Everything about the Mini Tricopter Receiver Trouble

This topic contains 2 replies, has 3 voices, and was last updated by  Kingscoop 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #39267

    swparrish14
    Participant

    I am in the process of building the mini and have gotten to the part where I need to set up my receiver. However, I can’t get Betaflight or Cleanflight to respond on the receiver tab to my sticks. I have tried all of the UART lines and a totally different transmitter and receiver. That leads me to believe there is something wrong with my set up but I can’t figure out what.

    I know they are bound because when I turn on my Transmitter it says I have the RX signal.

    Transmitter: FS-I6
    Receiver: nazflyskyia6

    #39270

    biggestRCEfan
    Participant

    I had the same problem on my quad. Receiver bound and no joy in getting tx commands through. I knew the FC board and motor setup was good as I was able to flash the ESCs and spin up the motors from the motor tab. I also had telemetry coming through. I even swapped out receivers suspecting the sbus connection not being good.

    Then I noticed the sbus was not connected to a UART but to led port adjacent to it (betaflight F3 FC). This solved the problem.

    So make double sure you have the Rx connected correctly to the FC.

    #62978

    Kingscoop
    Participant

    I’ve only just got round to assembling my Mini-Tricopter and have got to the same problem as swparrish14.
    I have a Taranis Q X7 transmitter, FrSkyX4R receiver and the F3FC flight board.
    I have bound the receiver to the transmitter – green light when the transmitter is on, red light when off and the transmitter recognises that the model is still powered up when switching the transmitter off. I, therefore, assume that the receiver and transmitter are talking to each other.
    The receiver is plugged into the top row of pins which I think is UART1. The fourth white wire from the receiver is disconnected. Is there a diagram of the connectors?
    I have triflight_0.7_Beta3_RCEXPLORERF3.hex installed in the flight controller and Cleanflight recognises movement of the tricopter.
    No idea what some settings should be, for example:- ESC (Powershot125?). I have set the receiver to serial and SBUS and in the ports tab have set the serial RX to UART1.

    On another matter, after assembing everything I’ve noted that all three motors are CCW versions (EMAX RS2205), is that right?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.