Home Forums Everything about the Baby Tricopter "Tail drop" while hovering

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #37143
    BlueMan
    Participant

    Hi everyone!

    I’m trying to success a maiden with my baby tricopter, but it’s pretty hard. Let’s explain:

    First my setup is an rcexplorer FC and pdb, with little bee 20A esc and zmx 2206 motors. The Fc is flashed with triflight 0.6

    When i take off an try to hover, everything goes pretty well until the tail motor stops for a very short time like 0.1s, which result in the tricopter to go upside down. This cut appears randomly, i can’t find the source: no max throttle, no movement on any axis…

    I replaced the esc by another littlebee but nothing change… I modified a bit the pwm values on blheli suite, in case of, but i don’t have any result.

    Do you guys have already experienced something like this?

    Thank you for your help !

    #37153
    LitterBug
    Participant

    TriFlight 0.6 was not recommended for general use due to several issues with it. I would recommend using 0.5 or downloading 0.7 which was just released today.

    Cheers!
    LitterBug

    #37177

    Interesting. Had the same issue with my Martian recently.

    #37186
    BlueMan
    Participant

    Hi guys,

    Thanks for your answers 😉

    It turned out that triflight 0.6 works pretty well, the esc too. It was a failed motor, although it was fresh out of the box. So now i fly with two zmx 2206 in the front and an Emax 2205 at the back 😀
    It flies good!

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Everything about the Baby Tricopter’ is closed to new topics and replies.