Home Forums Everything about the Mini Tricopter Tail Tune results

This topic contains 64 replies, has 29 voices, and was last updated by  biggestRCEfan 2 years, 2 months ago.

Viewing 15 posts - 46 through 60 (of 65 total)
  • Author
    Posts
  • #27563

    Terje
    Moderator

    @lauka, sorry for being so dense, but I haven’t been able to getting the tail tune to work 🙁 Could you clarify a few things?

    ARM the tricopter, then turn on tail tune. Tail tune will start after 5 seconds after tail tune is activated whether the tricopter is on the ground or in the air (During tha time you hear 5 beeps at 1 second intervals?). Does it matter which flight mode the tricopter is in? Angle/Horizon or rate?

    When tail tune is active, what should you be doing? Just make sure it is level and hovering and try to keep your hands off the sticks? What is the beep pattern while calibrating? What is the “done calibrating” beep pattern? How long does it take? (I can’t hear the beeper over the props)

    When calibrating is done, you land and disarm, wait 10 seconds and turn off tail tune? Is there a beeper pattern that tells you it is safe to turn off tail tune? Do you need to save the result afterwards? If yes, how do you do that?

    Hope you can help me understand 🙂

    #27797

    Siclair
    Participant

    Tail tune is not working correctly on any of my tricopters.

    Have a stand alone Naze on my Titan and the built in on the Rcexplorer. Within 2 seconds of taking off the finish beeps start.

    Never hear any beeps in between. It’s the finish beeps instantly. Tried it several times. Indoors and outdoors. This on Triflight 0.4.

    #28057

    Bengt
    Participant

    I have done some testing with the tail tune in 0.5 Beta 2. A lot actually.
    The algorthms are now working for me.

    From this i’d say the critical issue is the deadband settings. After I had adjusted my endpoints I noticed that the mid was not exactly centered. I raised the deadband and the tuning worked as advertised. Beeps and automatic save included.

    So if you too have problems here: check your deadband settings again!

    #28058

    lauka
    Participant

    @bengt: good find! How much did you have to increase the deadbands?

    #28065

    Bengt
    Participant

    I bumped them up to 15 just to be on the safe side. Next time I will check more accurate what I need. I think less will work and it’s easy to test.

    #28072

    Joost
    Participant

    So even though the pots in your controller do not need a larger deadband (mine flick between 1-2us from center) setting deadband to 10us helps? Does TT ‘skip’ deadband area to test if thrust/angle have any effect? i.e. does it need/assume a minimum angle away from 90 deg?

    Also is it general deadband, or just deadband_yaw? Or both?

    Been trying to read through the code on github to better understand whats going on but my complete lack of C knowledge & function documentation (just some java/matlab) makes it tricky.

    p.s. Things I did learn: Lumenier Lux FC does not have hardware support for separate servo/ESC PWM timers.

    #28086

    lauka
    Participant

    It uses the normal deadband for pitch&roll and yaw_deadband for yaw. If your gimbal channel jitter stays under the deadbands there should be no need for increasing them.

    I’m thinking of increasing the default deadbands from 5 to 10.

    #28109

    Ralph
    Participant

    Hey guys,

    I have some problems with the tail tune.
    First of all, I cant enable tailtune + arm the board (like david said in the video) because it will block all Tx inputs somehow.
    So I armed first and enabled tail tune… sadly I had an faulty old SN20A still on the left side which stopped working neary at the end of the tuning process.. I guess… however, do I need to clear the saved result? and how?
    Because it seems like I cant run the tail tune again after the first “maybe”-run.

    Thx for your help.

    #28110

    Bengt
    Participant

    It’s a good idea to always save your CLI dump for comparison in a case like this.

    This time you should be ok with these CLI commands

    
    set tri_tail_motor_thrustfactor = 138
    save
    

    But you can start with get tri_tail_motor_thrustfactor and check. Maybe it never changed the value.

    #28319

    Joost
    Participant

    Occasional breeze

    Mini tri
    Emax RS2205 – 2300KV Motors
    HQ6x4.5 Propellers
    4S 1300 mAh battery
    BMS-210DMH Servo 5v

    # version
    # TriFlight 0.5 Beta 1/NAZE 2.1.2 Jan 25 2016 / 20:14:56 (c68285a)
    # get tri_tail_motor_thrustfactor
    tri_tail_motor_thrustfactor = 130

    # get tri_servo_angle_at_max
    tri_servo_angle_at_max = 400

    #31306

    sscott
    Participant

    Stock mini tricopter with F3FC frame and the electronics kit (the one with the EMAX motors)
    No FPV gear
    Stock props

    Servo uses feedback wire.
    Setup servo using David’s servo adjustment tool.
    Tailtune was run on a day with only a very slight wind (only had to move the sticks twice). Tailtune took about 60 seconds. Tailtune was performed in angle mode.

    TriFlight 0.5 Beta 3/RCE 1.12.0 May 17 2016 / 18:19:11 (e463d95)

    tri_servo_angle_at_max = 400
    tri_tail_motor_thrustfactor = 68
    tri_tail_servo_speed = 290

    Does the low value of 68 seem ok for the tri_tail_motor_thrustfactor? Everyone earlier in this thread was getting much higher values.

    #31310

    Bengt
    Participant

    If the value is half of the default value it could mean that the prop is only giving half thrust with the same torque. If that is true maybe you have the prop upside down.

    With a certain torque, the servo has to compensate to keep heading stable. It has to tilt an angle from vertical. This angle is atan(1/F) where F is the tri_tail_motor_thrustfactor/10.
    Default F=13.8 means 4.1 deg. F=6.8 means 8.4 deg.
    (the tuning is based on that formula and takes the average of a lot of angle samples)

    So another explanation might be that your servo has a different idea about where the vertical is.
    You could recheck the motor center (the spline) when the servo is at 1500 and recheck the servo mid in the bench tail tuning. I use a white background and carefully look at the air gap between the motor mount and the fancy tool.
    If you only do the mid tuning, and skip the speed check, you have to save with stick commands (after you switched the tail tune mode off).

    #31343

    sscott
    Participant

    Ok yes, you are correct. The tail servo centers at 1567, not 1500.

    If I remember correctly, with the servo set to 1500, it was impossible to get the tail motor exactly centered, due to the size of the steps in the spline. So with the servo centered, the tail motor was a few degrees (I guess 8 degrees, in this case) from vertical.

    Is there any downside to the servo center being 8 degrees from vertical? I can’t imagine how this would affect the flight performance. As long as the firmware knows where motor vertical is, and it can move at least 45 degrees in either direction, it shouldn’t matter, should it?

    #31345

    Bengt
    Participant

    I don’t think so.
    (Strange thing will happen if the err is in the other way so this angle from vertical is <=0.
    When I see it keeping its heading when I go up and down I am happy.

    One time I tried a different verification. I configured a separate profile that was identical except for the yaw I term which was 0. If it can keep its heading in hover and when going up/down it must be perfect; No static errors for the integrator to handle.
    Wanted to see if I could design a tail tune that way but I gave up because always too much wind (and also too difficult to be sure the I term was restored properly).

    #34435

    billyd
    Participant

    I have found something strange, if I run in flight tail tune over and over again, the thrustfactor drops each time.

    I have a stock mini (with the older 2208 motors and sn20a esc’s). I am using triflight .5 latest as of the date of this post. I have the F3FC board.

    The first time I ran it I got 111
    Next 100
    and now it is 78.

    I was re-running it because first I changed the PIDs, and then second I balanced the props. Not sure if you have to re-run inflight tail tune each time you change anything but I figured better safe than sorry.

    Why does it keep dropping? Coincedence? Perhaps I should increase it in CLI to 150 and run it again. Perhaps it is not attempting higher values?

Viewing 15 posts - 46 through 60 (of 65 total)

You must be logged in to reply to this topic.