Home Forums Everything about the Baby Tricopter 6S Tri-Baby build (Matek F405-AIO)

Viewing 15 posts - 61 through 75 (of 90 total)
  • Author
    Posts
  • #57605
    Kevin_Erik
    Moderator

    Impossible Tail-Mech arrived!

    So far everything looks good but i am waiting for my servos to arrive.

    #57811
    Kevin_Erik
    Moderator

    The Impossible Tail-Mech has been installed and flown with 6S today. Maxed out around 46 Amps per motor or 91% of full throttle before the limiter kicked in to save the ESC’s.

    Edit: BlackBox Log file was too big to upload to the forums so i’ve added it to Google Drive: https://drive.google.com/file/d/1KLJjNwpeJDezMr_f3tjsPdD9Pq38SNEt/view?usp=sharing

    image

    image

    Flew it pretty damn hard such that I had screws that had backed out of the motor mounts!
    image

    # version
    # Triflight on Betaflight 3.2.2 v2 / MATEKF405 (MKF4) 3.2.2 Dec 31 2017 / 15:24:22 (30f68c8) MSP API: 1.36

    # name
    Tri-Fury

    # resources
    resource MOTOR 1 C08
    resource MOTOR 3 C09
    resource MOTOR 4 NONE
    resource MOTOR 5 NONE
    resource MOTOR 6 NONE
    resource SERVO 1 C06
    resource SERIAL_TX 2 NONE
    resource SERIAL_TX 11 A02

    # servo
    servo 5 1090 1964 1533 100 -1

    # feature
    feature ANTI_GRAVITY
    feature DYNAMIC_FILTER

    # map
    map TAER1234

    # serial
    serial 30 32 115200 57600 0 115200

    # aux
    aux 0 0 0 1700 2100
    aux 1 1 2 925 1300
    aux 2 2 2 1300 1700
    aux 3 28 2 1700 2100
    aux 4 37 1 1700 2100

    # master
    set gyro_sync_denom = 2
    set gyro_notch1_hz = 0
    set gyro_notch2_hz = 0
    set dshot_idle_value = 400
    set motor_pwm_protocol = DSHOT1200
    set failsafe_off_delay = 30
    set failsafe_throttle = 1100
    set failsafe_kill_switch = ON
    set failsafe_procedure = AUTO-LAND
    set align_board_roll = 180
    set bat_capacity = 1000
    set ibata_scale = 179
    set servo_center_pulse = 1520
    set servo_pwm_rate = 250
    set tri_tail_motor_thrustfactor = 73
    set tri_tail_servo_speed = 258
    set tri_servo_feedback = RSSI
    set pid_process_denom = 2

    # profile
    profile 0

    set dterm_lowpass_type = PT1
    set dterm_lowpass = 70
    set anti_gravity_gain = 3000
    set yaw_lowpass = 40
    set p_roll = 45
    set p_yaw = 105
    set d_yaw = 30

    # rateprofile
    rateprofile 0
    set rc_expo = 20
    set rc_expo_yaw = 20

    #57819
    Kevin_Erik
    Moderator

    These look like nice motors for the Baby: https://www.getfpv.com/tmotor-f60-pro-ii-1750kv.html?

    #57821
    LitterBug
    Participant

    F40 pro II would be more than enough for the baby tri. Not sure going to F60 would gain much. The F40 ProII are capable of 1800g thrust each. I’ve got Edge R2205 2480kv on one baby, and Cobra 2207 2450kv on the other. Those are more than enough for a baby tri. The Edge are crazy light and responsive. I’ve had to detune it quite a bit to keep it from oscillation on all axis. I’m actually thinking of updating my first Mini tri from F40 2300kv motors to a set of F40 Pro II 1600kv. Have a set of those on a 5″ quad build, and it rips bawls. If I wasn’t already working an F80 mini build, I might consider turning mini 1 into an F60 build, But Really gotta have at least one “tame” build. LOL

    LB

    #57823
    Kevin_Erik
    Moderator

    I think I’ve almost all traces of Tail-wag gone! Just had a flight that was excellent with only minor snap back after turns. Even prop wash was muted compared to before. Seams as if the Yaw Terms, specifically the “P” has to be very high for it to be effective. Thus far I’m at 170 from 105 previously.

    Note: Will post a video soon.

    # version
    # Triflight on Betaflight 3.2.2 v2 / MATEKF405 (MKF4) 3.2.2 Dec 31 2017 / 15:24:22 (30f68c8) MSP API: 1.36

    # resources
    resource MOTOR 1 C08
    resource MOTOR 3 C09
    resource MOTOR 4 NONE
    resource MOTOR 5 NONE
    resource MOTOR 6 NONE
    resource SERVO 1 C06
    resource SERIAL_TX 2 NONE
    resource SERIAL_TX 11 A02

    # servo
    servo 5 1090 1964 1533 100 -1

    # feature
    feature ANTI_GRAVITY
    feature DYNAMIC_FILTER

    # map
    map TAER1234

    # serial
    serial 30 32 115200 57600 0 115200

    # aux
    aux 0 0 0 1700 2100
    aux 1 1 2 925 1300
    aux 2 2 2 1300 1700
    aux 3 28 2 1700 2100
    aux 4 37 1 1700 2100

    # master
    set gyro_sync_denom = 2
    set gyro_notch1_hz = 0
    set gyro_notch2_hz = 0
    set dshot_idle_value = 400
    set motor_pwm_protocol = DSHOT1200
    set failsafe_off_delay = 30
    set failsafe_throttle = 1100
    set failsafe_kill_switch = ON
    set failsafe_procedure = AUTO-LAND
    set align_board_roll = 180
    set bat_capacity = 1000
    set ibata_scale = 179
    set servo_center_pulse = 1520
    set servo_pwm_rate = 250
    set tri_tail_motor_thrustfactor = 81
    set tri_tail_servo_speed = 258
    set tri_servo_feedback = RSSI
    set pid_process_denom = 1

    # profile
    profile 0

    set dterm_lowpass_type = PT1
    set anti_gravity_gain = 4000
    set dterm_setpoint_weight = 100
    set p_pitch = 43
    set i_pitch = 30
    set d_pitch = 26
    set p_roll = 49
    set i_roll = 30
    set d_roll = 48
    set p_yaw = 170
    set d_yaw = 45

    # rateprofile
    rateprofile 0

    set rc_expo = 20
    set rc_expo_yaw = 20

    #57825
    LitterBug
    Participant

    Loctite blue on the the motor mounts, And make sure you are engaging the “ny” on your nylock prop nuts. Stuff shouldn’t be falling off. šŸ˜›

    Cheers!
    LitterBug

    #57826
    Kevin_Erik
    Moderator

    #57828
    Kevin_Erik
    Moderator

    @LB

    I recall being told off the other day for no reason other than replying to you.

    #57829
    LitterBug
    Participant

    ā€“<< I must Fly more >>ā€“

    Shutting up and flying ā€¦.

    #57831
    Kevin_Erik
    Moderator

    Well as your so fond of context….

    I refered to you as a “Sourpus” simply because your taking things too seriously with your grouchy disposition. You should lighten-up when something irritates you rather than lashing out. Beyond that, if you prefer we can simply agree to not reply to each others threads. Sounds childish but hey if that’s what it takes then by all means.

    Edit: Here’s an idea… Lets just drop this and both stop acting like retards.

    #57832
    lauka
    Participant

    @Kevin_Erik: that starts to look good. You could try increasing the Yaw D term, it is not doing much at the moment.

    I will do some flight testing myself soon.

    #57835
    Kevin_Erik
    Moderator

    @Lauka Any thoughts on how much ā€œDā€ to add? Also be aware that my non-standard configuration may not be the same as your Tri.

    #57843
    LitterBug
    Participant

    I have a better idea. Next time you think my panties are in a bunch, Just tell me to shut up and fly! I obviously haven’t been flying enough.

    Cheers!
    LitterBug

    Edit: PS. Got a few packs in last night and already starting to feel better! šŸ˜€

    #57845
    Kevin_Erik
    Moderator

    Video or it didnt happen!

    #57848
    Kevin_Erik
    Moderator

    Today while adjusting my Telemetry I noticed that my Gyro is not longer detected nor can i calibrate the accelerometer! WTF, i just installed this damn FC last week!

Viewing 15 posts - 61 through 75 (of 90 total)
  • You must be logged in to reply to this topic.