Home Forums Everything about everything else Tricopter build with yaw concept

Viewing 15 posts - 16 through 30 (of 41 total)
  • Author
  • #60767

    I don’t have a good answer for you, as I’ve never had a violent autotune, it’s always been pretty sedate.

    I would try this. Before running autotune, reset all the gains to their default values, and then take the default values and knock them down by 50%. The copter should fly, but it will feel loose and sloppy. Then try the autotune. If it is calm, proceed, if it’s violent, stop and reduce the default gains some more.


    I had a similar issue the first time i Autotuned my Bicopter. Motors were scorching hot to the touch and the process itself was very “angry”. Now as Mr. J stated, you can reduce the defaults to the point you no longer see / hear bad behavior. It will fly, yet be about as controllable a herd of cats. I think i sawpped out my ESC’s, don’t totally remember as i’m on meds for pain.

    Side note: Recheck your ESC’s using BLHELI to ensure all three use the same firmware and are slaving to the master ESC. ( normally the tail motor) A simple missed selection on any one ESC can cause the copter to randomly desync at a time of it’s choosing.

    Question, which motor failed?


    -NE motor burnt
    -ESCs were “NOT in SYNC with MASTER” because ‘max throttle’ was not the same for all ESCs, so I correct it. But My Master is ESC_1 and is not linked to the tail motor. See picture.

    I reset all PID to default, as well as all Triflight values (Tau, Beta, etc) Maybe it is the key before re-autotuning

    Now it flies again, at least in hover. I just auto-tune in the underground carpark (no violent oscillation), however :

    -After the auto-tune, Yaw PID values were extremely high (about 5 times too high, and highlited is orange in GCS). I decreased manually Yaw P & I (and put D to 0) to be able to take-off again for tail-tune.

    -After this last tail-tune, the tail motor is now twitching in idle (stop-start-stop-start) like if idle was too low. But when I import the previous settings, the motor works fine again in idle, with the same idle value in GCS, i.e. 100)

    I will re-tune again tomorrow…


    LOL, FOUR ESC’s on a tricopter…?
    You know, if your still seeing four ESC’s in BlHeli then I’d say swap out the ESC’s one at a time to isolate which one is misbehaving. After that, toss it. For the three installed, you should only see those three, not some phantom ESC. On a relatively new build or one made from salvaged parts, its wise to do a BL-Heli sweep. Easy to do and saves alot of headaches.

    Question: Your ESC’s run BlHeli but are not from them? I saw the manufacturer name on the ESC’s and was like “what F is that”?

    Now as for your other problems. Try Defaulting all your settings be re-installing your firmware. While this seams like a total pain, it will prevent you fom missing any settings that may contribute to a bad tune. Anyways, all this trial and error will pay off, just takes time.

    BTW: Throttle setting when using dShot are alot easier to do and should auto-sync. The other non-dShot protocals all require bench calibration prior to flight.


    I’m trying to setup all manually…

    Can you please check the attached picture.
    -Are the input command values correct ?
    -I don’t understand the message from the CONFIG box. What to do ?



    First off the error shown is the Autotune…. Its saying that your have neglected to goto the Autotune “tab” and enable it, while yet this is an active option within your flight modes. Easy fix!

    Will look over the image in just a moment.


    Ok, the image shows your RC inputs. Its super easy to verify if your receiver is active while your connected via your USB port. If you check, you may discover that your receiver is active and can see the signals from the RC. Just move each corisponding Axis and flip each Switch to ensure that they work and show over the full range of your sticks travel. Nothing should go off-screen or be out of view. When your sticks / switches are at Min/Max/Center, you should always see them.

    Orherwise… if your Receiver isn’t being powered via USB, you can connect your battery. Just keep our props off and keep it disarmed to ensure nothing blows up.

    Side note: be aware that one or mre axis may need to be reversed to move the copter in the correct direction. Otherwise your stick inputs with have the wrong effect and lkely crash you.


    OK thanks, I just forgot to SAVE after enabling Autotune…

    Now I’m not able to arm. Is it due to the fact that the throttle is not detected as LOW ?

    EDIT : I’m using “arm by switch” option

    • This reply was modified 4 years, 2 months ago by Fosch.

    Beyond choosing a “switch” to Arm your copter, I think you’ll need to set a failsafe specific timer within the Arm’ing tab. From what I’ve read, 3 Seconds should do nicely. Here you can also set for how long the Gyro self-calibrates before flight. 3 Seconds is good here too as the delay after Arming gives you a moment or two prepare before lift off. Its much better then having it insta-launch uncontrollably. Just rememeber this when you Arm for the first time and nothing happens… wait for it and Zoom.

    Note: Smoke-Stopers are awesome Bech-Tools for preventing electrical shorts for when an ESC, MOTOR or other component decides to let the magic smoke out. Here’s the one i use: https://m.youtube.com/watch?v=qZm7oJoyaFs

    Before flight please bench check the Copter without props, yet fully armed. Watch how each Motor responds as you provide RC inputs to verify the correct Motor / Servo output. Should a Motor or Servo move the wrong way, adjust with BlHeli (Motors) or reverse it from the Output-tab (Servos).

    Furthermore, pick up the Copter in your hand (not plugged into USB) at just above idle Motor speed (10-15%) and move it around like your flying. (no props) You should see the Copter attempt to fight the changes in motion. This should be relative to the amount of force and direction your using. If its working you’ll know as you can “feel” it in your hand. Its like it’s alive and all pissed off that you made it move.

    Note: I highly recomend making screenshots of all your dRonin settings once your know everything is working. Preferably before you fly, just in case something bad happens. Like, why re-invent the wheel right?

    Be aware, that Tailtune is in ACRO MODE yet Autotune is in HORZ MODE. This is part of how its scripted. (Mr. J can confirm) Obviously this can make Tailtune very challenging if your not expecting to manage the copters orientation manually. (crash, bang ect)

    On your first flight Tail Wag / Oscillation can be very common upon Arm’ing but should stop / signifigantly reduce as more throttle is applied. If not lower you default PID’s a wee bit. (too much P is usually the problem) During your first flight, you should Tailtune and save it. Performing the steps David indicated in his video too. Look for the Tail tune result, if its 13.5 or 13.8 (i forget which) then the Tune failed. Check your Tailmech and Servo settings and try again.

    Once the Tail-Cal is Golden, Autotune as normal just run with lower PID’s this time. This is assuming they’ve not already been tweeked lower. If Autorune gets crazy STOP! Otherwise after about a two minutes you can Land, save and plug in to your PC. Using your advanced mouse skills, click “next” a bunch of times until dRonins main config screen pops up. At that point PRESS SAVE, then open the Stability tab to note the tune values. Reboot and go fly!

    Note: Never Autotune over a preexisting tune. Always “Default” the Stability-Tab PID’s first!


    Thank you Kevin_Erik for all the details.

    # Always “Default” the Stability-Tab PID’s first!
    It seems that all tuned values (like Tau, Beta, etc.) must be reset in my case before re-autotuning, not only PIDs.
    I would suggest to add a button in the GCS to erase ALL tuned values

    # Arming
    Finally I’m able to arm now ! Explanation :
    When I changed MotorSpinWhileArmed to TRUE in the “Ststem” tab, it doesn’t save it. I must click the cell in the output tab to get it working

    If weather is good today, I will try to re-tune. I’m just afraid about the overheat from yesterday, I hope another motor or ESC will not fry when I will put full power…


    Saving after every change is a dRonin thing and possibly a Betaflight one too. Idea is that unless you Save, the config only exists on your GUI. This allows you to tweek away at settings without impacting the Copter, whilst doing so.

    Now as for your sugestion, Mr. J would have to chime in on that one.

    About your previous burn-up issue, “IF” your sure your ESC’s and Motors are good then you should be fine. Doesn’t hurt to bench check the copter and push all your motors to 30% just to make sure that they dont desync under load later. Ideally you’d do this without the PC connected, using only the RC to manually throttle up. (no props)

    Question: How many ESC’s do you see in BlHeli now, three or four? If the Answer is anything like your last BlHeli screen-shot, then I wouldn’t fly it until you figure out why. Might be worth swapping the ESC’s out just in case you still see four, when three are installed.


    I have 4 ESCs in BLHeli simply because it is a 4-in-1 ESC and all 4 wires are connected, initially to flash all ESCs to the last BLHeli firmware 🙂

    OK, so now it flies, not too bad I would say, but still a lake of stability after hard acro :

    I already increased the DynamicYawMinThrottle to 3 and the YawBoost to 5, but still some Yaw after a punchout when I cut throttle :

    And right after a Tail Tune, the tail motor doesn’t start or clogged when armed. It starts to spin after increasing the throttle. I tried to increase motor idle speed, without success.

    • This reply was modified 4 years, 2 months ago by Fosch.

    Videos look great!

    Your Motor start issues could be one of the following:

    -Bad ESC 4in1. Look for FOD (loose solder) or bad solder points on the card
    -Lose solder join to from Motor or ESC.
    -Motor screws making intermittent contact with Motor windings, effectively shorting it to ground. Yet in this case, your “ground” is the carbon frame. This will 100% cause the motor to desync, burnup or act squirrelly as all “F”

    The BIG question i have: Is it the same Motor position that got Smoked earlier? IMO, i feel this is an ESC issue. Being that this is an 4 in 1 combo, you can just replace it so easily. However you can use a Magnifying glass to examine it in detail. Look specifically for solder-balls and loose components.


    Front-right motor burnt,
    While tail motor doesn’t start (or clogged) after arming (but starts after applying throttle)

    This issue happens only after a tail tune, not with default parameters.
    When I check using the GCS tab, all 3 motors start to spin exactly at the same value (72).

    Question : is the motor speed right after arming equal to the idle value defined in the output tab ? or is it another speed value ?

    PS: To be sure, I will check if there could be a ground issue due to motor screws.


    Yeah the motor minimum speed set in GCS is the speed the Motors will start at once the Copter is Armed.
    Really, though… Ohm out All your Motors and do a detailed inspection of the ESC 4-in-1. Your Motors should all read very close to each other in comparison regardless of which leads are being Ohm’d out. (This assumes that they’re not connected to the ESC at the time)

    IMO Odds are really high that your ESC is bad on one channel. Case in point, cold solder joints can act up when the components heat up. This places stress on the solder joint causing it to break its physical connection. However, the positions of all the pieces involves is so close that the Electricity can still arc across allowing for some level of operation. That being said, there is a point where the system will start to Desync from the electrical noise generated from the arcing.

Viewing 15 posts - 16 through 30 (of 41 total)
  • The forum ‘Everything about everything else’ is closed to new topics and replies.