Home Forums Everything about the Tricopter LR Tricopter LR – Firmware (Triflight, iNav)?

This topic contains 109 replies, has 11 voices, and was last updated by  swissfreek 2 months ago.

Viewing 15 posts - 31 through 45 (of 110 total)
  • Author
    Posts
  • #61821

    jihlein
    Participant

    “It was a little fiddly at first (the connection from dRonin GCS and the computer failed often)”

    Yeah, for some reason the GCS has always been a little flaky on WIndows. Linux and MACOS seem to behave better, I’ve no idea why.

    “But I can not see the “Tailtune” option in the flight modes as described in Davids video”

    Since “TailTune” doesn’t really tune the tail, just calibrates the some servo parameters, I change the name to something less misleading. The instructions have not caught up with that.

    “I do not know if telemetry down link is even possible with crossfire”

    I’m not familiar with the Crossfire system, hopefully someone else can help here…….

    “Also it seems that dRonin does not support smart audio to configure your VTX”

    It’s coming, along with OSD menus for a few other things. I need to finish testing.

    “I hope that the new version(s) will be fully supporting the tricopter and not requiring another “special release” [1] which is not linked on the official dRonin page”

    Not likely, I had a PR written for it but there was no interest in adding it to the mainline. I keep this branch up to date with official dRonin – it’s currently rebased to their latest “next” version.

    #61829

    oxivanisher
    Participant

    Thank you both, @swissfreek and @jihlein for your answers!

    > TailTune is called ServoCal now. | You will get telemetry via CrossFire.

    Thanks for those infos *thumbsup*. I will test that.

    > It’s coming, along with OSD menus for a few other things. I need to finish testing.

    Verry happy to hear that!

    > Yeah, for some reason the GCS has always been a little flaky on WIndows. Linux and MACOS seem to behave better, I’ve no idea why.

    My workshop PC is actually running a Linux (Ubuntu). But I did not find the custom GCS for Linux why I had to use my gaming PC for this. If you need someone to compile it for Linux i.E. I will most likely be able to help. My day job is Linux system engineering in a dev company. “DevOps”

    > Not likely, I had a PR written for it but there was no interest in adding it to the mainline. I keep this branch up to date with official dRonin – it’s currently rebased to their latest “next” version.

    This is very sad. If you want to try it again, I would certainly support you if possible.

    #61830

    swissfreek
    Participant

    Glad that was helpful.

    I have found the Mac GCS to be flaky as well with regards to the connection. It’ll be fine, then suddenly “NO LINK”, then I’ll click to a different tab and it’s back, then it’ll lose link again. Meh, it works sufficiently to do what I need (if I can figure out why the compass isn’t registering). Beyond that I just want to get out and fly!

    #61831

    jihlein
    Participant

    I wonder if there’s a problem with the HMC5883 code I implemented, as I had trouble with it too. I chalked it up to a bad compass unit and got a new one, which worked. But now that I sit back and think about it, my new one is an HMC5983…….

    I’ll take a look.

    #61833

    jihlein
    Participant

    @swissfreek – the simple act of connecting an HMC5883 to my KakuteF4V2 caused it to completely flake out. So I dug out a spare, and connected the HMC5883 to it. The new board works fine with the HMC5883.

    So the takeaway is:
    1)The code is good.
    2)I’ve either got a bad board or did a bad job soldering to the original one. Going to try that old one again when time permits.

    All I did was set ExtMag to External HMC5883 on the Hardware pane, save, and reboot. The Magnetometer object then started showing active, non-zero, x, y, and z mag values.

    #61834

    swissfreek
    Participant

    Hm, OK, I’ll try again, then.

    I switched back from iNav to dRonin. Using “Export Settings” didn’t bring everything back. Mainly the output settings (left right center tail servo settings and motor idle). All the triflight settings were there, though.

    #61841

    swissfreek
    Participant

    OK, tried again with the magnetometer several times, nothing. So I guess I will pick up that GPS module that you have with a 5983 that you know works for you. Is it possible there’s a difference between a 5883 and 5883L? Is there even such a thin as a 5883 or are they all just 5883L? Because apparently that’s what mine is, but it also looks like that’s what they all are that I can see. It’s weird to me that it seems to work in iNav but not in dRonin. The wiring is SCL->SCL and SDA->SDA, yes? Not crossed like a UART would be?

    Another note, I’ve tried to enable VTOLPathFollower, and it doesn’t seem to enable. I assumed this was because the magnetometer wasn’t detected, but it doesn’t throw an error or anything, it just stays grayed out. When I enable PathPlanner, *then* I get an error state on PathPlanner which says “No Path Follower enabled” or something to that effect. Makes me wonder if there just isn’t something else wrong with my setup again.

    #61861

    jihlein
    Participant

    @swissfreek – don’t order the GPS just yet, let me do a little more testing. I have it working with a 5883L breakout board from Sparkfun I found, I want to try it with a Ublox M6N unit I have that also has the 5883L on it.

    It’s strange that you can make it work with iNav and not dRonin. I want to see if there’s any difference in how the two firmwares are configuring the I2C port too.

    #61983

    swissfreek
    Participant

    So, I just noticed that iNav has two listings for 5883s, one for the HMC5883, and another for the QMC5883. I assume that since there’s separate listings, there is something different in the implementation? Mine is apparently a QMC5883, not HMC. Perhaps that’s the issue I and others are having.

    #61993

    swissfreek
    Participant

    So, I purchased a GPS with (supposedly, this is all from China after all, who knows what’s real?) a HMC5983 magnetometer (the Holybro M8N). I set it accordingly in the GCS and… I still get all 0s in the Magnetometer Data Object and the magnetometer calibration still times out. So, I have no idea what’s going on with my setup. Mildly frustrating.

    #61999

    jihlein
    Participant

    @swissfreek – I’m feeling your frustration too. I’ve got a number of things going on with this board I can’t explain. I’ve got a situation where on dRonin, the mag (HMC5983) and gps work fine. Move to iNav, and the mag works, but the GPS doesn’t. Absolutely no idea why. Also issues with the SmartAudio, can’t get any life out of that function at all.

    I’m leaving on vacation for a week here shortly. Going to put things aside for a bit and maybe I’ll have some better luck when I get back……

    Forgot to post this:

    I was unaware of the QMC5883, it’s a different beast and NOT compatible with the HMC5883 driver, so it won’t work with dRonin. Here’s list of the major differences I found posted on a different project:

    Main differences between both chips:

    I2C address (QMC: 0x0D vs HMC: 0x1E)
    Different ODRs (QMC: 10Hz, 50Hz, 100Hz, 200Hz vs HMC: 0.75Hz, 1.5Hz, 3Hz, 7.5Hz, 15Hz, 30Hz, 75Hz)
    Data register address (QMC: 0x00:05 vs HMC: 0x03:08)
    Data order (QMC: 0x00.XLSB, 0x01.XMSB, 0x02.YLSB, 0x03.YMSB, 0x04.ZLSB, 0x05.ZMSB vs HMC: 0x03.XMSB, 0x04.XLSB, 0x05.ZMSB, 0x06.ZLSB, 0x07.YMSB, 0x08.YLSB)

    • This reply was modified 3 months ago by  jihlein. Reason: Added QMC5883 info
    #62001

    swissfreek
    Participant

    Well I suspect now we know why “some” 5883s work and others don’t. Looking around the various sites, it seemed like more compasses were QMC vs. HMC. Cursory googling says the QMC is a cheaper component, so that makes sense.

    Bummer that you’re having issues, too, but enjoy your vacation! On the plus side, my Tricopter flies quite well without any navigational aids, so other than me busting teeth on the tail servo and having run out of props, there’s nothing stopping me from flying 😉 I’m convinced my issues with the mag are still my doing, so I’ll keep trying and see what I can come up with. Might also try tuning iNav some more, but I suck at tuning, so I don’t know that I’ll be able to improve anything.

    As for Smart Audio, I’m a CrossFire user, and I bought my first TBS Evo in anticipation of using it with dRonin, so I can connect directly via CRSF and change settings that way (OSD, too I believe). If you’ve got an older TBS VTX that isn’t 32-bit, and you’re a CrossFire user, you can still connect one of the spare pins on your CrossFire receiver to the Smart Audio pin of your VTX and control it that way as well. I don’t fly with others very much, so it’s rare for me to have to change channels anyway.

    • This reply was modified 3 months ago by  swissfreek.
    #62004

    swissfreek
    Participant

    Ah! Mystery solved on my end. The new GPS module I got does NOT, contrary to the product listing, have a HMC5983 mag in it. It is in fact a QMC5883. Thanks a lot, GetFPV.

    Found an interesting GitHub thread in my googling about this issue today (they seem to have found a kludge solution, but anyway):
    https://github.com/betaflight/betaflight/issues/4531

    Interesting comment here about how the QMC5883 came about because Honeywell discontinued the HMC5883/5983 and licensed the chip to someone else:
    https://github.com/betaflight/betaflight/issues/4531#issuecomment-437412221

    Elsewhere in the thread there’s comments (which you’ve already sort of covered @jihlein) that talk about the different addresses, but also notes that there’s a bug in the first version of the QMC that caused it to be respond to calls intended for a HMC5883. That’s not the issue I was having, I’ve confirmed mine are both Rev B. Might it be worth looking into implementing the QMC5883 given that I think it’s highly likely that the majority of folks will have that compass and not a HMC? As I’ve said plenty of times, I have no idea how much work that entails, but I figured it’s worth asking.

    Anyway, looks like, as I guessed, the problem is still with me, and not the code. Now to write a sternly-worded email to GetFPV… 😉

    I bought that one because the one you linked on Amazon of course was sold out the day I decided to buy it. But now it’s back in stock, so I snagged it. Cheaper, too. Hopefully I can put this to bed for good now.

    • This reply was modified 3 months ago by  swissfreek.
    #62007

    Kevin_Erik
    Moderator

    @Swiss You should contact GetFPV and politely make them aware of this fact. Odds are that you’ll find that they maybe accommodating or at the very least update the products description.

    #62010

    Tim
    Participant

    Because the HMC5883 and HMC5983 Sensors were discontinued by Honeywell some time ago, I was browsing through the dRonin Sourcecode & Docs to see if their replacement, the LIS3MDL, is supported. Seems that way. I ordered a DP0107 (M8N GPS + LIS3MDL) from Drotek in france. These are high quality boards similar to the ones from CSG Shop, but this particular model also has affordable pricing and mounting holes with 30 mm x 30 mm spacing for the LR’s top plate. Takes a week or so to arrive, I will then try to find some time for testing and report back if it works.

    Edit: I just found some discrepancy in Drotek’s offering. The specifications list a mag-sensor and I2C connection, but the product images don’t reflect this. Guess I’ll know when it arrives…

    • This reply was modified 3 months ago by  Tim.
    • This reply was modified 3 months ago by  Tim.
Viewing 15 posts - 31 through 45 (of 110 total)

You must be logged in to reply to this topic.