Home Forums Everything about everything else Triflight 0.7 Beta 1

This topic contains 142 replies, has 32 voices, and was last updated by  bhuism 2 years, 2 months ago.

Viewing 15 posts - 91 through 105 (of 143 total)
  • Author
    Posts
  • #37563

    Dave Mak
    Participant

    I haven’t installed triflight .7 on a SPF3 board yet (I only have triflight .7 working on a RCExplorerF3 board), but I do have Betaflight 3.1.6 working on my SPF3 tricopter.

    Not sure what ESC’s you’re using, but maybe instead of using multishot, try oneshot125 or even standard PWM to see if that solves the motor issues. The motor resource mapping looks fine to me for a SPF3.

    I don’t see a servo mapping with your setup so that might explain why you can’t get the servo to respond. It would depend on what pin you connect your servo to, but I have mine connected to PWM pin 4 output which is A12 on the SPF3, so this is what I used to map my servo for my setup: resource SERVO 1 A12

    #37565

    Micropitt
    Participant

    Thank you for the tip with the servo:
    # resource
    resource BEEPER 1 C15
    resource MOTOR 1 A06
    resource MOTOR 2 A07
    resource MOTOR 3 A11
    resource MOTOR 5 B08
    resource MOTOR 6 B09
    resource MOTOR 7 A02
    resource MOTOR 8 A03
    resource SERVO 1 A12

    I’m really not sure why the motors not spinning. The ESC’s are all reporting fine in BLHeli Suite. I did try Multishot and Oneshot but the ESC’s should be doing DShot. They were advertised as DShot 600 ESC’s. I could try different motors…..

    #37567

    Micropitt
    Participant

    Some small success. Motors are spinning if I set them to “PWM” in the Configurator tab. However, they run almost full throttle at idle. I did calibrate them through Betaflight. The servo is moving a little tiny bit but not as it should be.

    #37568

    Micropitt
    Participant

    Motors2 and 3 (front motors) are spinning normal now. Motor1 doesn’t. If I arm it spins up to full throttle. Interestingly, when I unplug Motor1 from the FC, go in to the Betaflight Motor Tab and then arm, I still can see Motor1 tab going up to 2000 while Motor2 + 3 are staying at 1070.
    I would be thankful for any hints or tips….

    #37569

    Dave Mak
    Participant

    I’ve found that most esc’s I’ve bought that advertise as “blheli” or “blheli_s” have all had older versions with various bugs or even beta features. Just because they advertise the dshot, etc capabilities doesn’t mean the software on them might be ideal for those features.

    Did you connect either blhelisuite or the blheli chrome configurator to see what version and settings you have on those ESC’s? I can verify that triflight does the blheli passthrough perfectly.

    If you do reflash or update those ESC’s, just be very careful and follow all the usual precautions:

    * No props
    * Voltage/Current limited supply or “smoke stopper” device in line
    * Double-check you are flashing the correct version for your hardware

    #37571

    Micropitt
    Participant

    The ESC’s are looking fine in BLHeli Suite and the current version is 14.9
    I happen to have a second identical FC which I just have setup with iNav 1.7 and in this setup everything is working as it should.
    At this point in time I’m a little bit confused why things are working with iNav but not with TriFlight. It seems that TriFlight differs more from the Cleanflight/Betaflight code than I thought.

    #37572

    wheelyjoe
    Participant

    Here’s what I’d do (I just finished setting up this baby)

    1. Fresh install of triflight
    2. If you plug the battery in, take the props off and arm the thing do the bars in the motors tab go up when you throttle up?
    (I monitor quite a lot of stuff here)

    If yes: Make sure your ESCs are getting power and all the right beeps are being made when you power up, should be on output pins 1 (rear), 2 (right, looking from behind towards the front), 3 left.

    If no: Make sure you’re actually arming it, and getting receiver signal, that’s a different kinda problem.

    3. For the servo you have to remap servo 1 to motor 7s pin, to do so, type in the CLI:

    resource motor 7 none
    resource servo 1 A02
    save

    and then obviously plug the servo into pin 7.

    If you want to test the servo, you can also type in the CLI:

    set tri_unarmed_servo = ON

    This lets the servo do it’s thing while the motors are unarmed, but that can burn out a servo in no time.

    Also regarding the servo, is it analogue, or digital? If it’s analogue you’ll have to set the servo rate, again in the CLI:

    set servo_pwm_rate = 50

    If it’s digital, you’ll have to check, but it’s normally around = 333.

    If that doesn’t work, get back to me and I’ll see what I can come up with.

    This is assuming you’ve got your hardware right, if you’ve got that wrong it’s harder to help with over the web, but I’ll see what I can do!

    ALSO: set servo_lowpass = ON is broken in betaflight and by extension triflight, and I didn’t realise and had problems similar to you.

    #37578

    bhuism
    Participant

    @micropitt, maybe I didn’t read it correctly, but if the motors work on PWM the connection is fine. I would advise to allways update the ESC blheli firmware + fc software to most recent version, if you can. If you want to run dshot make sure you do the cap removal, that could explain why pwm is working and dshot is not.

    see bottom of the page: https://github.com/betaflight/betaflight/wiki/DSHOT-ESC-Protocol for cap removal details.

    #37579

    Micropitt
    Participant

    Thank you all for the advice, tips and hints.

    @bhuism the ESC’s have worked in a previous setting and as I stated above, still working with iNAV 1.7 on a identical FC which makes me think that my issue is within Triflight.

    @wheelyjoe I will follow your advice and then report back. The servo is a digital servo: TGY210DMH
    I’ll try it out tonight.

    #37580

    bhuism
    Participant

    So, inav with DSHOT works, Triflight with DSHOT does not work?

    #37581

    Micropitt
    Participant

    Not only that. I have to set it to PWM (they don’t spin at all with oneshot, multishot, dshot) in order to make the motors spin. On top of that, Motor1 (back motor) will spin full throttle as soon as I arm. It is really strange.
    In my setup with iNAV 1.7 the motors will spin normal in PWM, oneshot, multishot and dshot which tells me that motors and ESC’s are fine. The only thing I haven’t tried yet is to get Triflight on the FC that is currently running iNAV. The FC in both cases are identical SPRacing F3.

    #37582

    LitterBug
    Participant

    iNAV is not based off betaflight but rather a fairly old version of cleanflight. It has the dshot code merged into it. We are not comparing apples to apples.

    #37584

    Micropitt
    Participant

    @wheelyjoe I followed all your suggestions…..and it’s all working 🙂 motors are running as they should, servo is moving as it should. It’s perfect.

    #37607

    JukkaAakko
    Participant

    Here are my first impressions of Triflight 0.7 Beta 1:
    First I tried 0.7 in a big tricopter and immediately noticed yaw drift -> I did set tri_motor_acc_yaw_correction = 0 and drift was totally gone.
    Yesterday I got my little tricopter rebuild finished, flashed triflight with filter_fix version and did a quick test hover indoors-> yaw drift was there. Setting tri_motor_acc_yaw_correction = 0 solved the drift issue again.
    So I took a look at the source code and noticed that tailMotor.virtualFeedBack is calculated from motor signal and only when motor is decelerating -> expected gyro error is therefore set always to same direction and this will accumulate as yaw drift over time. Filtering is step to right direction, but there will be always fluctuations in motors, caused by vibrations, corrections for turbulence etc.. This correlates what I have noticed during flight: when flying low (like 20cm) the drift is more obvious, because of turbulent air.
    So her comes the interesting part @lauka: I decided to redo feedback for tri_acc_correction. I used rcCommand[Throttle] to calculate (RC) virtual feedback for gyro error. I did hover test again and drift is gone. Hopefully I have change to do a real test flight this weekend…

    #37612

    wheelyjoe
    Participant

    Great! Happy to help!

Viewing 15 posts - 91 through 105 (of 143 total)

You must be logged in to reply to this topic.