Home Forums Everything about everything else Triflight 0.7 Beta 3

Viewing 15 posts - 16 through 30 (of 117 total)
  • Author
  • #40108

    @ biggestRCEfan

    I was able to turn the P-gain down a bit which did seem to help.
    Also I tried a new set of propellers from Master Airscrew (6×4.5×3 BN) with which I could hover for 5.8-6.2 Amps continuous current draw. The HQ 6x4x3BN’s in comparison draw just over 8 Amps for a similar flight weight.

    BN-3blade-FPV – 6×4.5 Prop Set x4 Black

    The hover times were just short of 13.5 minutes. Freestyle flying was 8-9 minutes depending on how aggressively it was flown. With the HQ props i was lucky to see 9 minutes of hover or 5-6 minutes of freestyle flight.


    Hi Lauka,
    Thank you for all your hard work!

    I had the beta 2 firmware on my v4 tricopter with the stock electronics kit and it worked fine.
    I just flashed the new beta 3 firmware and entered this diff which is the same as I used beforehand into the cli:

    # diff
    # Triflight 0.7 Beta 3 / RCEXPLORERF3 3.1.7 Oct 21 2017 / 13:57:41 (17fa321)
    name Jordy’sTricopter
    servo 5 968 1911 1471 40 40 100 -1

    feature TELEMETRY
    feature CURRENT_METER
    aux 0 0 0 1400 2100
    aux 1 28 0 1900 2100
    aux 2 1 1 1900 2100
    aux 3 2 1 1400 1600
    aux 4 13 3 1900 2100
    aux 5 31 4 1900 2100
    rxfail 5 s 2000
    set min_check = 1005
    set max_check = 2000
    set motor_pwm_protocol = MULTISHOT
    set align_board_pitch = 180
    set tri_tail_motor_thrustfactor = 95
    set tri_tail_servo_speed = 320
    set baro_hardware = AUTO
    set mag_hardware = AUTO
    profile 0

    rateprofile 0
    rateprofile 0


    I’m not sure why but now when I try and arm the motors, it just beeps instead. I was hoping someone could help me fix this? Otherwise I’ll just keep running beta 2 for now.
    Thank you, Jordan 🙂


    There is a new safety feature in Beta 3 which prevents arming if the tail servo feedback signal is invalid. Did you rerun the unarmed tail setup + speed calibration?



    Thank you for your work. I just installed Beta 3 on a Trifecta:
    frame : Trifecta
    motors : 2206 RCX 1950 kV
    props : carbon T-Style 7×2.4
    esc : ZTW Spider pro OPTO 2-4S
    Battery : 3S
    FC : Omnibus F4 with SD Card
    Target : OmnibusF4SD

    I have two issues. First, the servo wobbles when throttle is low, on the ground or in the air.
    Lowering manually tri_yaw_boost seems to calm the wobble down but i loose the yaw authority.
    Secondly, tail tune doesn’t change any CLI value. I checked with a diff and no parameter changes.

    Anybody encountered the same issue(s)?




    Hi again,

    I went back to Beta 2 for comparaison.

    I have the same issue with tail tune who doesn’t change anything in CLI but my servo doesn’t wobble at low throttle anymore. I manually tuned tri_tail_motor_thrustfactor to 70 to not have yaw on throttle punch.

    The PIDs are the stock ones but i think they need some tuning.
    Here is a video of flight in acre mode and sometimes in horizon mode:


    1. triflight.txt

    Just ran the unarmed tail setup + speed calibration and now motors are running.
    Will run inflight calibration soon and see how it flies. 🙂
    Thank you lauka


    Hi Jorter,
    How do you run the speed calibration when you don’t have a feedback wired (id VIRTUAL i guess)?



    Hi samp38,
    I think it works the same but without the servo moving. Then if you have a beeper it will still make the complettion sound, otherwise you’ll just have to wait for a while to make sure it’s done.
    I’m no expert though, I think that’s just what David says in his triflight setup video.
    Someone else can probably help you better… 🙂



    Just thought I’d let you know that BLHeli_32 is having some issues with Triflight 0.7 Beta 3.

    After installing / Throttle Cal’ing my new Aikon AK32 35A Esc’s I found two of the motors to be spinning in the wrong direction. Next I loaded into BLHeli_32 to attempt to reconfigure the motors. Passthrough connection was good but BLHeli_32 could not read the ESC’s. (syntax: serialpassthrough 0 115200)

    Troubleshooting, I next flashed Betaflight RCEXPLORERF3 Version 3.2.2 (Binary betaflight_3.2.2_RCEXPLORERF3.hex to see if this made any difference. It did as it was able to read the ESC’s. Unfortunately BLHeli was only able to see two of the three ESC’s and could only spin up the ESC’s it was able to see.



    Betaflight 3.2.1 (and 3.2.2 apparently) has the motor mapping wrong for Tricopter, so you might have to do some resource remapping. You can copy the mapping from Triflight 3.1.7 though.

    Not sure if BetaFlight 3.1.7 which Triflight is based on for now, supports BLHeli_32 passthrough.


    So odds are that anyone building a tricopter using the new ESC is in the same situation as me.
    And its also likely that remapping from an older version wouldn’t work if it not likely to support the 32 bit ESC’s.


    Depending on which flight controller you are using. The RCExplorer F3 boards don’t use DMA channels for the motors, so no Dshot or Dshot_32 support anyway – as I understand it.


    I will just invert the front two motors for now. Always wanted to try this anyway.


    Just did a test flight with the front two motors inverted.
    Works like a charm!

    Skids from [email protected], POC “Brian”.

    Will come up with a way to invert everything soon as i ca figure out how to keep the tail servo from pivoting into the ground. Could possibly flip the body and then mount 60mm landing skids on the now underhung body. This would place the center of gravity about even with all the motors.


    First time setup of a tricopter with the newest triflight beta 3, and I’m not sure what I’m doing wrong. I’ve used the tail tool calibration tool according to David’s video and everytime I save the setting and go to arm the copter, the tail motor tilts to the right. Video below. Please help!! I’m so frustrated over this. Thank you!

    Triflight Center Tail Servo Issues

Viewing 15 posts - 16 through 30 (of 117 total)
  • The forum ‘Everything about everything else’ is closed to new topics and replies.