Home Forums Everything about the Mini Tricopter Triflight setup guide

This topic contains 255 replies, has 71 voices, and was last updated by  danieee 3 weeks, 6 days ago.

Viewing 15 posts - 226 through 240 (of 256 total)
  • Author
    Posts
  • #38266

    BLeeK
    Participant

    @ Pietro
    Not sure if you’ve noticed elsewhere on forum, but dRonin is set up/optimized for tricoptors. servo-feedback & all…. 😉

    #38270

    Pietro
    Participant

    Inav optimized? I’ll look for it

    edit
    I realized Dronin is based on openpilot/taulabs.. I was using them with CC3D and Flip32.
    I don’t really like these GCS, I prefere Cleanflight/betaflight configurators, in my opinion they are simpler and cleaner, a question of taste.

    I think I’m going to wait for the betafight 3.2 release and subsequent Triflight update.
    It seems that GPS and Mag will be re-added.

    Thanks

    #38914

    Mark
    Participant

    Hey guys, just got all my parts for the mini tricopter and I’m having some trouble with cleanflight. I’m wondering if anyone could help. Every time I connect the copter to my computer, cleanflight says there is an issue with out of date firmware and I don’t know what needs updating. I have version 2.1.0 of cleanflight, which should be the latest version, and the hex file that I flashed the F3 board with is from rcexplorer.se, I’ve even updated my computer to see if it would fix the problem but it didn’t work. I would appreciate some help.

    Thank You

    #38915

    biggestRCEfan
    Participant

    Mark, I believe you need an older version of cleanflight Configurator to run the older versions of triflight. For the triflight versions currently I under test you need the latest version. From memory there are some posts on this forum showing how to do it.

    #39128

    swparrish14
    Participant

    I am having trouble with my left ESC. When I try to test the motors using betaflight, motors 1 and 3 work but motor 2 does not. So my first thought was the ESC was messed up so I flipped the arms and tried again. Same thing happened motor 2 would not work. Then I tried to read the left ESC output on the PCB and it didn’t have a voltage like the right ESC did. So I am at the point that I think something is wrong with the board.

    Anyone have another solution that I haven’t tried? I even tried to find another point on the board that the left ESC signal is available but couldn’t find one.

    Please help, I just want to fly my mini!

    #39146

    swparrish14
    Participant

    Having problem connecting to cleanflight? Update to triflight 0.7

    This is the latest firmware, I had the same problem this is what David sent me.

    #39247

    dnhuffman
    Participant

    I bought rcexplorer Mini Tricopter built it to the point of setting it up on cleanflight. I can flash in DFU mode but then can’t go any farther. I try the DFU drop down and it only shows manual connect and another window for the port that is not filled – tried the physical port name for the STM32 BOOTLOADER (and severial “com1,2 etc names) but still nothing. I am using windows 7 and did install the drivers requested. F3FC board is in boot mode (solid green led) and I have tried it when it is flashing blue and red but still no good. Can you show me what I am doing wrong or do I have a hardware problem? every time I try to connect I get “Failed to open serial port” yet I can load the firmware. I tried Inav and it shows “/dev/rfcomm0: in the Port Window but it does not connect either. Will try a new USB Cable tomorrow. if that does not fix it do I have a bad board? or am I messing up somehow? I found the problem when not in DFU mode I have an error code that is the same as another had on the forum the code is for main board not linking to Gyro ic 3-4 fast flash and then 2 slow

    #39657

    Borneoben
    Participant

    Hi Guys

    I have searched for the last two hours where to connect the servo feedback wire to my Afroflight 32 rev 5 board.
    It has been flashed with Triflight 0.7 using Betaflight. Servo feedback is set to RSSI in the CLI
    set tri_servo_feedback = RSSI

    But which pin on the board is the RSSI pin???? Im going nuts trying to figure this out.

    Any advice is greatly appreciated.

    Ben

    #39660

    Borneoben
    Participant

    I am assuming its one of the input pins close to the RX inputs?

    #39676

    rue
    Participant

    Hi Ben, this should be PIN 4 (the one labeled “2” next to your RX input on the upper side of the board). See also here http://shipow.github.io/cleanflight-web/docs/board-naze32.html

    Have not tried it myself but I hope this works for you 😉

    Best, Rue

    #39677

    Borneoben
    Participant

    Many Many thanks
    I have seen that document but wasn’t sure if it was referring to pin 2 or 4.

    Ill report back when its all set up.

    Cheers

    #39853

    Kevin_Erik
    Moderator

    Anyone know if there is a version of our triflight firmware that provides support for the Runcam-Split?

    I am currently using triflight_0.7_Beta2_RCEXPLORERF3.hex but find that there is not native support to the Runcam OSD peripheral.

    Cheers!

    Kevin

    #57491

    chilternflyer
    Participant

    Hi guys,
    Has anyone got a CLI setup for the V3.5 tricopter with an RC explorer Naze using triflight 0.7?
    I’ve just put it on my Naze but I’ve got no idea what CLI settings to use with this version.
    Everyone seems to be using the F3 and have forgotten about the naze users.:-(

    #57878

    Bojan
    Participant

    Hello! I am using an old flip32(F1) board and I also have same issue with tail servo. While in onboard calibration the endpoint of servo both for left and right are reached(like 40degrees). Then afther calibration is saved and when I arm the board it will only yaw like 20degrees on left and just some 5-10d to the right). Any ideas. I am running TRIFLGHT 0.7 on CF. Thanks

    #58161

    FPVienna
    Participant

    Just semi-finished my new vintage-babytri.

    Naze rev5, blheli 14.9 esc’s, dys 1806, triflight 0.7 Beta3

    After a first test hover (little tail wag in no-throttle, but hovered nicely after that), i can declare this little bugger a success! 🙂

    Used Pins 3, 4 and 5 for Motors, No. 1 for the servo. The servo feedback wire goes to RC 4 (the RC Pin with “2” printed next to it).

    The config i changed is as follows:
    # diff
    # Triflight 0.7 Beta 3 / NAZE 3.1.7 Oct 21 2017 / 13:51:32 (17fa321)
    resource MOTOR 1 B07
    resource MOTOR 2 B06
    resource MOTOR 3 B08
    resource MOTOR 4 NONE
    resource SERVO 1 A08
    resource SERVO 2 NONE
    servo 5 981 1849 1430 40 40 100 -1

    feature -RX_PPM
    feature RX_SERIAL
    serial 1 64 115200 57600 0 115200
    aux 0 0 0 1900 2100
    aux 1 1 1 1900 2100
    aux 2 2 1 1400 1600
    aux 3 31 3 1900 2100
    set motor_pwm_protocol = OFF
    set serialrx_provider = SBUS
    set tri_servo_feedback = RSSI

    have fun! 🙂

Viewing 15 posts - 226 through 240 (of 256 total)

You must be logged in to reply to this topic.